5

I've added the following line into my startup applications:

/usr/bin/syndaemon -i 0.5 -d -K

but syndaemon is never running when I log in. I always have to execute the command manually from the terminal, at which point it works normally. My other startup applications work fine. This issue occurs in both gnome and unity.

I'm using ubuntu 14.10 (issue occurred in 14.04 as well). I doubt my hardware matters, but I'm on a lenovo yoga 2 pro.

Ideas?

  • I don't know syndeamon, but is it possible that it is started before its "environment" is ready? It is a common reason for startup applications / processes to crash. Add a pause of 10-15 seconds before it starts (sleep 10) may help. You can edit the (automatically created) startup- .desktop file like in this example: askubuntu.com/a/562376/72216 (skip the rename- section of course) – Jacob Vlijm Jan 2 '15 at 19:42
  • Jacob -- This worked perfectly. Can you post as an answer so that I can give you credit for it? – Michael Jarret Jan 3 '15 at 4:55
  • Glad it worked! Added my answer. – Jacob Vlijm Jan 3 '15 at 6:58
4

I am not sure what Syndeamon is or should do, but it could very well be that it is started too early, and crashes because the desktop is not fully loaded yet.

What you can do is to add a small pause of 10-15 seconds to the start up command.

To do that:

  • Open the automatically created .desktop file in ~/.config/autostart (drag it over a gedit window)
  • Replace the line, starting with

    Exec=
    

    change it into:

    Exec=/bin/bash -c "sleep 10&&/usr/bin/syndaemon -i 0.5 -d -K"
    

You can experiment a bit with the time to optimize it.

Explanation

Some commands break if you add them to startup applications, because they need a fully loaded desktop to run succesfully, and Startup Applications runs the commands too early.

Touchpad- related commands are in that category, and then you need to add a little break after startup to make it work.

Since Startup Applications creates a .desktop file in ~/.config/autostart to run the startup command, you need the "regular" syntax to add a complicated command to be used in a .desktop file, which is in this case:

/bin/bash -c "sleep 15&&syndaemon -i 0.3 -d -K"
  • wait... but I want syndaemon to be active even before I log in... at the log in screen, if I log in as another user, etc... this answer doesn't make sense to me - how do I do that? – Michael Apr 23 '19 at 0:54
  • Thanks @Jacob. 15 didn't work for me. Neither did 30. 60 worked for me. – joker Apr 25 '19 at 23:56
0

Search for and open Startup Applications from the Dash. Click Add.

Name: Syndaemon

Command: syndaemon -i 0.5 -d -K

Comment: Disable touchpad while typing, with a reasonable delay and only for tapping and scrolling

Click Add and then Close.

Reboot your computer.

Note: this is a user preference, so repeat this in every user account.

  • This is what I did. This is what is not working. – Michael Jarret Jan 2 '15 at 19:05
  • Try disabling the 'Disable touch while typing' option in settings first. Then add the startup entry and reboot. Do you have any other touchpad settings packages installed? Is this a Synaptics touchpad? – Babbzzz Jan 2 '15 at 19:28
  • how to make this work at the login screen? – Michael Apr 23 '19 at 1:27
0

Command line

$(sleep 1; /usr/bin/syndaemon -i 0.5 -d -K )&

or

$( $(which syndaemon) -i 0.5 -d -K ) &
  1. Add this command into $HOME/.bashrc file (load your personal settings at login)

or

  1. Add this command to /etc/rc.local file(run this commands when system boot)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.