So I'm running Ubuntu 14.0.4 on my (Dell Vostro) laptop, and have a second screen plugged in. I use a normal USB mouse.

Usually, it works fine, but today (after hours of normal usage), I'm having this weird behavior, which I've had once before in the past:

I can't click on anything on my laptop screen (that's on the right-hand side), except the side and top bars - I can move the mouse all over the place, but there is no mousover or click events on any window on the laptop screen (things work fine on the external monitor).

And if I click on the Dash search, I get the search results full page, and the mouse works fine there (there are reactions on mousover and I can click). So it's as if there was this invisible window running above all the others, absorbing all the clicks, but that can still be overlapped by dash like all windows can (nothing of the like appears if I alt-tab around).

And if I unplug my desktop screen, clicking works fine on the laptop (and goes away once I plug it back in). And if I open the system settings and move the (virtual) relative position of my screens around, the problem will only appear on the right-side screen, whether it's the laptop or the external monitor. If I put the two virtual screens one above or below the other, I can click everywhere just fine, until I put the screens back next to each other - so it does really seem to be the "right hand side" going wrong, not the laptop screen itself.

Last time this went away when I closed my session and reopened it (locking it is not enough). I don't really know what more I could do to troubleshoot this.

Edit: clicking suddenly started working again once I finished posting this. Despite the fact that I did nothing "special" (I clicked on a chrome gmail window with a notification?), and had tried dozens of things while writing the problem report.

  • it might has to do something with the screen ordering.. which monitor is left and which is right.. I had the same problem and its been a work around for me to have my screens ordered (virtually) differently. – Markus Mar 20 '16 at 16:47
  • 3
    Same problem occurs randomly in Ubuntu 16.04. occurs on all 4 virtual desktops. Mouse-up events do work though - I can drag and drop onto the right-hand side. So do clicks on the status bar at the top of the screen (which I have put on both displays). – Sanjay Manohar Sep 8 '16 at 15:00

I had the same problem [Xenial], which seemed to be triggered by starting VirtualBox (though that could be a red herring). I fixed it by

unity --replace

Though that doesn't explain why it happened in the first place...

WARNING - this will close all your open applications, so save everything first!

  • 2
    I only have this behaviour with VirtualBox... this command will restart unity, and after that it's working again. Any progress on how to prevent this? – duedl0r Jul 14 '17 at 22:11
  • 1
    Works in 16.04. – Dinei Aug 29 '17 at 13:58
  • it it not a red herring. I can confirm it is virtualbox that triggers this. – Bartosz Radaczyński Oct 11 '17 at 12:46
  • This command resolved issue, however, it closed my eclipse and firefox. So save the work before firing this command. – Anil Bharadia Feb 20 '18 at 8:55
  • 1
    Thanks @AnilBharadia I really should have said that! answer updated. – Sanjay Manohar Feb 28 '18 at 12:55

I think I found a solution for this. I was having the same issue, unplugging and plugging the second monitor did nothing to solve to problem in a long term, so I tried other options regarding configuration.

I noticed that my laptop had a default resolution of 1366x768 and usually the second monitor has less than that. With those values the problem will be present, but when you set your laptop to 1360 x 768 the problem is fixed, at least for half hour now in my case.

Good luck.

Update: hours now, and working perfect.

  • 1
    Nope, that doesn't seem to match my situation: 1) my second monitor has a bigger resolution, and 2) when this bug happens, changing the laptop resolution from 1366 x 768 (it's default) to 1360 x 768 doesn't fix it. – Emile Mar 2 '15 at 15:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.