0

I have a dual boot system with Ubuntu and Windows 8. The grub boot loader fails to load Ubuntu.

It was automatically loading Ubuntu in few seconds but not anymore.

So, I manually choose Ubuntu but it shows some scripts and fails to boot.

Even Windows 8 doesn't boot.

It's now showing something like this: error: attempt to read or write outside of disk 'hd0'. Entering rescue mode..grub rescue> I tried this - grub rescue > ls (hd0) (hd0,msdos6)(hd0, msdos5) (hd0, msdos4) (hd0, msdos3) (hd0, msdos2) (hd0, msdos1) I then tried this- grub rescue > ls (hd0,msdosX) but it doesn't show which is my Linux file!! grub rescue> failed to read file. Please help me I have so many data in my pc :(

closed as off-topic by karel, Eric Carvalho, waltinator, BuZZ-dEE, Evandro Silva Jan 13 '15 at 11:37

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Eric Carvalho, waltinator, BuZZ-dEE, Evandro Silva
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please give us more information, like what error message do you get etc. – Paludan Jan 2 '15 at 12:25
  • It doesn't start from grub. The grub seems fine but Ubuntu is not loading!! – stephen Jan 2 '15 at 12:36
  • The scripts are like ata4:hard resting link, unhandled error, usb 5-1: Usb disconnect, new low speed device found etc. – stephen Jan 2 '15 at 13:05
  • Please check the answer here on how to update grub: askubuntu.com/questions/207663/… – Paludan Jan 2 '15 at 13:55
  • Not its not working now it's showing grub error – stephen Jan 2 '15 at 14:35
1

Sorry friends it's my fault, the problem was with the hdd and it wasn't detected in my bios but its really working now after I reinstalled in motherboard. I doubted so when I tried to install Ubuntu from live disk then it showed I don't have enough space. I was confirmed after checking it out in bios. Feeling relaxed. Thanks everyone.

0

Boot into Ubuntu DVD. Choose "Try Ubuntu" option when it does provide two options of "Try Ubuntu" and "Install Ubuntu". Then, open up the Terminal, type sudo update-grub. Upon executing the command, reboot the system and check out if it does boot. If the issue persists, comment the error message.

  • How to open terminal? Should I choose try Ubuntu then alt-cntl-t? – stephen Jan 2 '15 at 12:55
  • I choosed try Ubuntu and typed as you said in terminal but shows failed to get canonical parh – stephen Jan 2 '15 at 13:00
  • You could Ctrl+Alt+T to open Terminal. Then, you could type sudo update-grub. – Wolverine Jan 2 '15 at 14:32
  • No it doesn't work – stephen Jan 2 '15 at 14:48
  • Check out this link. howopensource.com/2012/05/…. – Wolverine Jan 2 '15 at 15:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.