Bluetooth is not detected in lenovo b40-70 laptop in ubuntu 14.04. I have tried installing bluetooth manager and it shows bluetooth adapter not found.

My lsusb output:

Bus 001 Device 002: ID 8087:8000 Intel Corp.  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub  
Bus 002 Device 004: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader  
Bus 002 Device 003: ID 0cf3:3004 Atheros Communications, Inc.   
Bus 002 Device 002: ID 5986:0652 Acer, Inc   
Bus 002 Device 005: ID 12d1:1f01 Huawei Technologies Co., Ltd.   
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  

I have also tried rfkill unblock all but nothing works... I do not want to switch to windows again as this laptop is giving me hell of a problems and this is one among them.


First thing you may need to do is

sudo apt-get install linux-firmware

I have one of these BT devices on my Lenovo and they can be difficult with firmware uploading to early during boot so please try the following

echo "blacklist ath3k" | sudo tee /etc/modprobe.d/ath3k.conf

Then edit /etc/rc.local

sudo gedit /etc/rc.local

And add the following above exit 0, as exit 0 must be the last line in the file

sleep 20
modprobe ath3k

save, exit program, and reboot

EDIT:A new kernel was released today that fixed the issue without the blacklist or the edits in rc.local. http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.19.1-vivid/ check arch to see if you have 32 or 64 bit system You can delete the blacklist with sudo rm /etc/modprobe.d/ath3k.conf and use gksudo gedit /etc/rc.local and delete the sleep line and

modprobe ath3k

Save, exit program

For 32 bit, download and install




For 64 bit




I don't have hybrid graphics so I don't know if this kernel will cause problems

  • the first command gives this output E: Unable to locate package linux E: Unable to locate package firmware – gunjan parashar Jan 2 '15 at 11:27
  • does similar thing can be done to enable finger print reader in the same laptop – gunjan parashar Jan 2 '15 at 11:29
  • Don't know about finger print reader, but edited answer to correct the first command but you must have already had linux-firmware installed – Jeremy31 Jan 2 '15 at 11:31
  • it is not working again please help me, my friends mock for this for using ubuntu instead mac or win – gunjan parashar Mar 6 '15 at 21:25
  • Edit rc.local again using the command in my answer and change it from sleep 20 to sleep 30 save and reboot as a 20 second pause may be borderline – Jeremy31 Mar 6 '15 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.