8

I was trying to fix a different problem when suddenly my screen switched upside down - rotated 180 degrees. How can I fix this. I'm on Xubuntu 14.10 and a Dell Latitude e6420.

  • Did you use xrandr in your attempt to fix? Try: xrandr --output <screen_name> --rotate normal if so, but you will have to find out your screen name from the command xrandr, look for "connected". (And you will probably hurt your neck doing so ;)) – Jacob Vlijm Jan 2 '15 at 9:06
  • just xrandr -o normal fixed it for me. No I haven't used this command before, I must've hit some hot key?! – Basel Shishani Jan 2 '15 at 9:55
  • Go for it. I don't know what has happened, but I was playing with screen resolutions trying to fix screen getting out of bounds; (where virtual display is larger than physical display). Again having occurred by inadvertently hitting some wrong key combo! – Basel Shishani Jan 2 '15 at 10:04
3

Somehow, the screen settings (xrandr) must have changed to "inverted" while you were trying to fix things.

You can fix it by running the command:

xrandr --output <screen_name> --rotate normal

or, (easyer) by simply loging out and back in :)

|improve this answer|||||
11

Even easier : xrandr -o normal

|improve this answer|||||
0

I just physically rotated my screen, Ubuntu 17.10 probably has some rotating sensors. Probably Gnome tablet program is active. It could be same in the xubuntu 14.10 ! Once it was fixed in the needed rotation I locked the orientation. Hope it helps someone.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.