In theory this scanner does work under Linux and Ubuntu. I've found this document that I tried to follow.


I install sane, copy firmware, confirm the location in the config etc. Everything looks good.

Potential problem areas

sudo sane-find-scanner


# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

found SCSI processor "Marvell 91xx Config 1.01" at /dev/sg5
# Your SCSI scanner was detected. It may or may not be supported by SANE. Try
# scanimage -L and read the backend's manpage.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04c5 [FUJITSU], product=0x128d [ScanSnap S1300i]) at    libusb:005:007
could not fetch string descriptor: Pipe error
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

Okay. So the scanner is detected and listed, it prints a bunch of extra noise that

# scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Okay, let's verify the firmware files:

ls -lh  /usr/share/sane/epjitsu 
total 136K
-rw-r----- 1 root root 65K Jan  1 17:49 1300_0C26.nal
-rw-r----- 1 root root 65K Jan  1 17:49 300_0C00.nal

Looking at the configuration file: (snippets)

# Fujitsu S300
firmware /usr/share/sane/epjitsu/300_0C00.nal
usb 0x04c5 0x1156

# Fujitsu S1300
firmware /usr/share/sane/epjitsu/1300_0C26.nal
usb 0x04c5 0x11ed

Last thing I tried was to pull the line from sane-find-scanner and update the config

sane-find-scanner returns a different product ID. I updated the config file above, restarted the sane service, I ran scanimage -L still, scanner not detected.

For reference I had this working on this same computer under a virtualbox VM. If I can get it to work under windows that would be ideal. Any suggestion would be much appreciated.

Update: I revisited the behavior after adding the 1300i firmware and it's still not working but.

Once in a while when I do run this is the output. If I run it again it'll fail.

scanimage -L
device `epjitsu:libusb:005:008' is a FUJITSU ScanSnap S1300i scanner

also sudo gscan2pdf and sudo simple-scan both fail to detect a scanner. It fails with and without sudo permissions.

  • The post by Gavin Carr can be helpful to you. May be you can try R&D inn UBUNTU done by him on CentOS, here is the Link. He had same issue in CentOS, then download new firmware related to S1300I specific. You can at least give it a shot. Hope this might turn helpful to you.
    – Novice
    Jan 6, 2015 at 9:22
  • Looks like openfusion.net/public/files/1300i_0D12.nal is required in the firmware. Gavin Carr's account suggests i1300 =/= i1300i. Jan 8, 2015 at 16:23
  • I did add the 1300i line and it's still no go. firmware /usr/share/sane/epjitsu/1300i_0D12.nal usb 0x04c5 0x128d I also looked at openfusion.net/linux/scansnap_1300i and it didn't yield any different results.
    – csgeek
    Jan 11, 2015 at 20:16
  • You may find this helpful: luuklangens.nl/blog/…
    – Elder Geek
    Jan 12, 2015 at 15:24
  • @ElderGeek that was surprisingly helpful. it's unstable, but I did manage to get a single page to scan. Trying to repeat the procedure and see how it goes.
    – csgeek
    Jan 13, 2015 at 4:35

2 Answers 2


Thanks to everyone who posted valuable info and links here. Without your posts, I would not have been able to figure it out.

This is a revised version of my earlier post that referred to Sane v.1.0.23 / Ubuntu 14.04. Sane v.1.0.23 detects Fujitsu S1300i scanner but then somehow gets stuck and finds no scanners on the second and subsequent runs of "scanimage -L", as described in previous posts.

Sane v.1.0.25 (Ubuntu 16.04) detects Fujitsu S1300i with "sane-find-scanner" or "sudo sane-find-scanner". However, "scanimage -L" or "sudo scanimage -L" does not detect S1300i on my Ubuntu 16.04 system at all.

The following procedure is designed to make Fujitsu S1300i work on an Ubuntu 16.04 desktop system. With appropriate modifications, it should work for other Ubuntu versions as well.

1. Obtain, compile and install the latest version of Sane

The following instructions are loosely based on the "Compile Sane From Source" article at the Ubuntu Community Help Wiki.

The commands below will install Sane into /usr/local. If you choose to install into /usr instead of /usr/local, review the "Compile Sane From Source" and use the appropriate switches instead of the ones used below. I recommend installing into /usr/local, because this will leave your stock installation of Sane intact in case you want to switch back to using the stock version.

Install prerequisites:

sudo apt-get install libusb-dev build-essential libsane-dev
sudo apt-get install libavahi-client-dev libavahi-glib-dev libjpeg-dev
sudo apt-get install git-core

Download the latest Sane:

git clone git://git.debian.org/sane/sane-backends.git

At the time of this writing, the latest commit is this one:

$ git log -n 1
commit 1e013654cc3af09f4731ab9ec8d8324d03a7de4a
Author: Alessandro Zummo <a.zummo@towertech.it>
Date:   Mon May 9 11:10:35 2016 +0200

Compile and install Sane:

cd sane-backends
sudo make install

If you decide to remove this installation of Sane, use "sudo make uninstall" to remove all installed files from /usr/local. This is a clean way to revert back to using the stock installation in /usr.

2. Register libsane

Check how your system finds Sane shared object library:

sudo ldconfig -v | grep libsane

If you see something like:

libsane.so.1 -> libsane.so.1.0.25
libsane.so.1 -> libsane.so.1.0.26

it means that the system first finds version 1.0.25 and then 1.0.26, which is not the correct order. In this case, you must change the order of the library paths in /etc/ld.so.conf or you must create a new configuration file for sane:

echo "/usr/local/lib" | sudo tee -a /etc/ld.so.conf.d/1-sane.conf

Once you have changed the library paths in /etc/ld.so.conf or created the new configuration file in 1-sane.conf, check the order of libraries one more time with "sudo ldconfig -v | grep libsane". Make sure that version 1.0.26 appears first before any other versions.

3. Install scanner firmware

Copy Fujitsu S1300i driver file, "1300i_0D12.nal", from the Windows computer where the scanner software was installed. Usually, this driver file is found in "C:\Windows\SSDriver\S300". Place the driver file into the /usr/local hierarchy:

sudo mkdir -p /usr/local/share/sane/epjitsu
sudo cp ./1300i_0D12.nal /usr/local/share/sane/epjitsu/

4. Adjust permissions to access scanner as a non-root user

The default udev rules set the ownership of the USB device to "root" and the group ownership to "root". Change the udev rules to set the group ownership to "scanner". Use your favourite editor to create this file:


and place the following into it:

# Fujitsu ScanSnap S1300i
ATTRS{idVendor}=="04c5", ATTRS{idProduct}=="128d", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

Add yourself to the "scanner" group if necessary:

sudo usermod -a -G scanner <username>

5. Finish installation

Reboot your computer. You may be able to start using your Fujitsu S1300i scanner without rebooting your computer, however a reboot is strongly recommended. I observed some odd behaviour with "scanimage -L" failing to find the scanner on a second run before a reboot even after making all necessary configuration changes. It could be that some libraries or drivers from the earlier version of Sane get "stuck" somewhere in cache or else. A system reboot cleans it all up.

After a reboot, connect your scanner, open the lid and execute:

scanimage -L

That's all. Enjoy your scanner.

  • It'll take me sometime to validate this, but if this works. You totally earned that bounty. :D
    – csgeek
    Nov 12, 2015 at 3:27
  • 1
    Here's what I've done. 1. I removed the old sane installation so it won't conflict with the from source install. sudo apt-get remove libsane libsane-common libsane-dev libsane-hpaio sane. 2. For reference my git checkout is: e6a249e0424f6854b7ed12f8272633a0edecfa90 latest tag: RELEASE_1_0_25 3. running scanimage -L gave me a .so conflict despite being build from source, so I re-install libsane and that seems to have fixed the error. Now, running scanimage -L gives me no scanners found.
    – csgeek
    Nov 16, 2015 at 1:46
  • Try to run "sudo scanimage -L" and see if it makes any difference. If it does, then you probably don't have permissions to access your scanner device as a non-root user. Run "lsusb" and see if your scanner device is there. If it is there, take note of Bus # and Device #, and then run "ls -l /dev/bus/usb/<bus#>". You should see the ownership and permissions of your scanner device (by its device #) in the list. If it is "crw-rw-r-- 1 root root", then yes indeed you don't have permissions to access the scanner as a non-root user -- most likely, due to your udev rules.
    – Beef Eater
    Nov 17, 2015 at 5:25
  • 1
    I have just followed the instructions above on my Ubuntu 12.10 installation, and it worked -- but only after I removed the existing sane installation. I am going to investigate a little further why the existing sane installation causes problems and update the instructions accordingly.
    – Beef Eater
    Nov 17, 2015 at 5:27
  • @csgeek: please check out the revised version of my post. It is possible that the proper registration of libsane, as described in "2. Register libsane" now, can solve your problem.
    – Beef Eater
    May 24, 2016 at 5:28

I've actually had good luck setting up the the ScanSnap S1300 scanner on a few Ubuntu installs. I just set it up on a 16.04 system this weekend. The instructions at http://luuklangens.nl/blog/howto-fujitsu-scansnap-s1300-s300-ubuntu-linux worked for me in the past but this post is no longer available.

As an alternative, the instructions at http://www.openfusion.net/linux/scansnap_1300i seem pretty applicable but I'll caution that it seems the difference between the S1300 and the S1300i is important. My specific process this weekend was to download both the 1300_0C26.nal and 1300i_0D12.nal files and then I picked up with step three in Beef Eater's response but installed both. After a restart, simple scan worked without issue. I did not build from source.

FYI - I apparently have saned 1.0.25+git20150528-1ubuntu2 installed.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.