0

When I run airmon-ng I lose all connection and I am unable to pick up any wifi network. I am running Ubuntu 14.04, Aircrack-ng 1.2 rc1 r2459 - (C) 2006-2014. If you need more information please ask.

  • Try with the command and scan the wi-fi connection :iw wlan0 scan. If you are getting the network while scanning it might be issue with network manager. – vembutech Jan 2 '15 at 7:48
  • possible duplicate of `airmon-ng` not working... Help please – SteveLacy Jun 24 '15 at 10:32
0

Using your WiFi adapter to scan for other networks in several channels (this means, in channel hopping mode) prevents you from using your adapter to connect to regular networks.

You can't do both at the same time. You either scan for networks and monitor traffic, or you disable airmon-ng altogether and use your WiFi adapter normally.

This is the command I use to stop all networking services and starting airmon:

sudo service avahi-daemon stop ; sudo service network-manager stop ; sudo killall wpa_supplicant ; sudo airmon-ng start wlan0

This is the command I use to stop airmon and starting all networking services:

sudo airmon-ng stop wlan0mon; sudo service network-manager start; sudo service avahi-daemon start

(Note that "wlan0mon" is the new notation for interfaces in monitor mode, starting with version 1.2-RC1. For previous versions, use "mon0")

0

You cannot easily put your device into mode managed and monitor (which is needed for aircrack-ng) simultanously. I think some devices support this, but most don't.

The problem is that you offcourse can't let your device be connected on a certain standard (n or g or whatever) and simultanously listen to ALL others, flying around.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.