3

My "Most Frequently Used" Applications in Unity Dash disappeared.

I tried to:

  • reset unity with unity --reset,
  • removing Zeitgeist history with rm ~/.local/share/zeitgeist/activity.sqlite, and even
  • reinstall zeitgeist via Synaptic,

but no one worked.

I also used Guest Session to check whether it only disappeared in my account, but actually not.

I don't know why it happened. How can I get it back? How do we reinstall unity and zeitgeist so that they really return to the state as when they are freshly installed?

Thanks in advance.

2
  • Possibly similar: askubuntu.com/questions/45560/… . It suggests re-installing unity-place-application and unity-place-files.
    – belacqua
    Commented Aug 13, 2011 at 20:42
  • @jgbelacqua Thanks, but I found that the problem is actually with zeitgeist config files in ~/.local/share/zeitgeist. I don't know exactly what files, but deleting the whole folder and generating a completely new one does the trick ^^
    – Inoe
    Commented Sep 9, 2011 at 3:13

1 Answer 1

3

Finally, found the solution myself ^^

I had another problem with file search, and tried to completely remove and reinstall the components of unity and zeitgeist many times but it didn't help. So I tried something else and found the solution.

Simply delete the ~/.local/share/zeitgeist folder (not just activity.sqlite), and restart the computer. It will generate a new and fresh zeitgeist folder, and the dash will be normal again.

Note: Just for safety reasons, I chose to rename the zeitgeist folder to zeitgeist.bak instead of completely deleting it, in case things didn't go as intended, because this was actually just a trial and success attempt :)

2
  • 1
    This doesn't fix the problem for me. Any ideas what else I can do?
    – Stephen RC
    Commented Nov 17, 2011 at 22:35
  • @Valorin Have you come across any other possible solutions? Aside from removing ~/.local/share/zeitgeist or reinstalling unity-place-application and unity-place-files?
    – Insperatus
    Commented Aug 25, 2012 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .