So I have found that update to a Wine issue regrading Qt5. The fix calls for me to compile and install Mesa 10.4.1. I got the source from git. So first I downloaded/installed the proper dependences such as flex bison autoconfig aclocal pkg-config and Util-Dev from repos. libdrm-2.4.58 pixman-0.32.6 dri3proto-1.0 and automake-1.14 were source built using ./configure and make/sudo make install. After I came across this in the Terminal after typing in ./autogen.sh

configure.ac:152: error: Could not locate the pkg-config autoconf macros.
  These are usually located in /usr/share/aclocal/pkg.m4. If your macros
  are in a different location, try setting the environment variable
ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.
configure.ac:152: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1

Proof in GUI

and when I run apt-file search pkg.m4 The Terminal results in

When I did download and ./configure and make/install those libraries, I left them in /Home. pkg-config: /usr/share/aclocal/pkg.m4 mm-common: /usr/share/aclocal/mm-pkg.m4

  • Did you install the pkg-config package on your system - if so how? Can you clarify which of the dependencies you have installed from the repositories, and which you are trying to build from source? What exactly do you mean by "left them in/Home" - did you configure them with --prefix=$HOME? – steeldriver Jan 2 '15 at 0:08
  • Pkg-config was installed via apt - get in terminal. – Virusboy Jan 2 '15 at 1:19

If you are using system autoconf, you must export

AL_OPTS=-I/path/where/you/installed/the/stuff/share/aclocal 

in your environment.

If you built and installed autoconf from source, you must export

AL_OPTS=-I/usr/share/aclocal

instead.

The point is that the /path/where/you/installed/the/stuff/share/aclocal or /usr/share/aclocal path you are putting into that AL_OPTS environment variable must be the one that contains the file pkg.m4.

If that does not work, try exporting ACLOCAL set to

aclocal [what you wanted to put into AL_OPTS]

instead, where the argument to aclocal in that variable is what you tried to put into AL_OPTS.

I ran into this same issue. What worked for me was installing autoconf and pkgconf. It was then able to find /usr/share/aclocal/pkg.m4.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.