I'm using Ubuntu 14.04 on my laptop and I can't connect to a specific WiFi networks. I managed to connect to others wifi networks in the past without any problem, and other devices (another laptop with Windows 7 and some Android smarthphones) were also able to connect to this WiFi network. Furthermore, this laptop can connect to the same router through the ethernet cable. So, as a resume, the problem is just between this particular device and this particular WiFi network.

Any hint about what may be happening?

I already tried solutions proposed on these questions but it didn't worked:

Can't connect to specific wifi network Can't connect to specific WiFi with 13.04

It seems that I don't have the iwlwifi but the wl instead. I also tried following those steps but replacing "iwlwifi" with "wl" but nothing.

Edit:

http://paste.ubuntu.com/9656647/

up vote 9 down vote accepted

From what I found on ubuntuforums.org you should

sudo apt-get purge bcmwl-kernel-source

reboot and you may need to blacklist b43 and/or ssb but you can try this after a reboot one line at a time and see if you are able to connect

sudo modprobe -r b43
sudo modprobe -r ssb

If you are able to connect only with using the modprobe -r b43 then echo "blacklist b43" | sudo tee /etc/modprobe.d/b43.conf

If it also took the modprobe -r ssb to connect then do both echo "blacklist b43" | sudo tee /etc/modprobe.d/b43.conf and echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/b43.conf and wifi should connect

  • 1
    It worked! I didn't needed to blacklist b43 nor ssb. Thank you very much! – matiascelasco Jan 2 '15 at 1:03

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.