1

I am trying to install Asterisk on my ubuntu system.I have sucessfully downloaded asterisk package and when i tried to build and install it using

./configure

its showing an error

configure: WARNING: *** Asterisk now uses SQLite3 for the internal Asterisk database.
configure: WARNING: *** Please install the SQLite3 development package.

then i installed the sqlite using the following command

 sudo apt-get install php5-sqlite //also tried the following
 sudo apt-get install sqlite3

After installing sqlite i am still getting same error while running ./configure

 configure: WARNING: *** Asterisk now uses SQLite3 for the internal Asterisk database.
 configure: WARNING: *** Please install the SQLite3 development package.

Can anyone help!

Thanks

  • typically development packages in ubuntu end with -dev. – T0xicCode Jan 1 '15 at 19:46
13

After searching a lot i got it fixed.Used the following command

sudo apt-get install libsqlite3-dev

Got it from this forum.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.