3

I was trying to set up a set of conkyrc files that I downloaded from https://www.youtube.com/watch?v=naZWkAWTDLU. It worked just fine, except for an issue I encountered which I don't know how to fix. The problem is that when Conky updates the information, it is not removing the previous information. As a consequence, as time goes on, data starts to pile and conky information becomes unreadable, besides ugly.

How can I fix that?? I have done some research on this issue but unfortunately I didn't find any related question. Thank you for your attention! I would really appreciate your help.

This photo shows Conky displaying processes info right after exectution starts

This first photo shows Conky displaying processes info right after exectution starts

This second photo shows the exact same conky instance a few seconds later

This second photo shows the exact same conky instance a few seconds later

PD I don't know what system information is relevant to this issue, but at least I can say that I am running Ubuntu 14.04. I installed conky through the terminal by typing:

sudo apt-get install conky

I can also show the conkyrc file that generates the instance I showed on the photos:

# Use Xft?
use_xft yes
xftfont DejaVu Sans:size=8
xftalpha 0.8
text_buffer_size 2048

# Update interval in seconds
update_interval 1

# This is the number of times Conky will update before quitting.
# Set to zero to run forever.
total_run_times 0

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_transparent yes
own_window_type override
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# Minimum size of text area
minimum_size 180 0
#maximum_width 200

# Draw shades?
draw_shades no

# Draw outlines?
draw_outline no

# Draw borders around text
draw_borders no

# Stippled borders?
stippled_borders 0

# border margins
border_margin 5

# border width
border_width 1

# Default colors and also border colors
default_color white
#default_shade_color black
#default_outline_color white
own_window_colour white

# Subtract file system buffers from used memory?
no_buffers yes

# set to yes if you want all text to be in uppercase
uppercase no

# number of cpu samples to average
# set to 1 to disable averaging
cpu_avg_samples 1

# number of net samples to average
# set to 1 to disable averaging
net_avg_samples 2

# Force UTF8? note that UTF8 support required XFT
override_utf8_locale yes

# Add spaces to keep things from moving about?  This only affects certain objects.
use_spacer none

# Text alignment, other possible values are commented
alignment top_left
#alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
# same thing as passing -x at command line
gap_x 236
gap_y 654


TEXT

${font courier pitch New Bold:size=11}${color #222222}PROCESSES ${color #222222}${hr 1}
${color #333333}$font${top_mem name 2}${alignr}${top mem 2} %
$font${top_mem name 3}${alignr}${top mem 3} %
$font${top_mem name 4}${alignr}${top mem 4} %
$font${top_mem name 5}${alignr}${top mem 5} %

One again, thank you for your help!!

2

In the .conkyrc file, the problem is where the line own_window_type is set to override. There are five possible values for this: desktop, override, dock, panel, and normal. The override mode causes drawing on top of itself when it updates (I have also experienced this). AFAIK, none of the other modes will do this, but certain modes don't play nice with desktop managers like nautilus. If you're using Unity, I suggest the dock mode; however, you will need to hold [Alt] and click-drag to move it to the desired position, as for currently unknown reasons the dock mode ignores the alignment, gap_x, and gap_y variables.

Full info for editing the .conkyrc file can be found here.

  • I tried the dock mode and as you said the problem disappeared, but another one occured: all applications were behind conky, whereas I only want conky to display on the desktop (any other window should hide conky). Moreover the alignment and gap variables were maintained. I tried the desktop mode and it is working perfectly, also alignment and gap are working. I realized by accident that by typing "deskop" instead of desktop, the conky instances became standard windows. The problem is solved. Thank you very much! – antortjim Jan 2 '15 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.