2

When I click on any Tomboy notes listed in Unity tray it sends me to the launcher where the Tomboy icon starts shaking and the note opens only after I click on the icon in the launcher. I need to open it with the single click on the list in the tray, how to do that? Previously I didn't have such problem. Ubuntu 14.04, Unity.

  • All I can say is that it works here (14.04) like it used to work in your case. It must be something on your system. What I don't understand: what has the image to do with the question :)?? – Jacob Vlijm Jan 1 '15 at 19:37
  • The image shows my screen after I click on any Tomboy note in the tray above. To open a note I need to click twice - on the tray and then on the launcher. I want to open it with a single click. – brijabasi Jan 2 '15 at 9:57
2

I've always had this same issue with Tomboy, but lowering the Focus and Raise behavior in CompizConfig fixes it. First install compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Run it with:

ccsm

Then navigate to General / Focus & Raise Behavior.

By default the Focus Prevention Level is set to Low and Tomboy always opens up behind other windows. If I change it to off, Tomboy opens up in front of other windows.

This may have other ramifications (other Windows may begin to steal focus, etc). You can set exceptions in this same settings panel.

Credit to this answer that I used originally to solve this.

  • You should detail the solution that you have as well as providing the link. – gman Jan 8 '15 at 15:39
  • @gman Updated it to include a summary of the solution – Mark H. Jan 8 '15 at 20:06
  • Wow, thank you very much, Mark H.! It solved the issue I have been annoyed by for a long time. Another side of it was the similar troubles with the message icon in the tray. Whenever new letters would come the message icon becomes blue, but when I click on it Thunderbird would not open but instead shake in the launcher. Now it also works. Thank you! – brijabasi Jan 11 '15 at 9:30
  • @brijabasi Glad to have helped! If you're all set please mark the answer as correct – Mark H. Jan 12 '15 at 15:17
  • 1
    @MarkH. Done that! – brijabasi Jan 13 '15 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.