1

When i try to start the lxc container created it fails with below error, I have used the Ubuntu template for this template.

It seems lxc is unable to drop the kernel privileges it is trying to drop, tried to figure it out but failed miserably.

can someone please help to get this solved.

Ubuntu version : 14.04    
kernel : 3.13.0-43-generic

Error:

lxc-start: conf.c: setup_caps: 2337 unknown capability mac_admin
lxc-start: conf.c: lxc_setup: 4172 failed to drop capabilities
lxc-start: start.c: do_start: 688 failed to setup the container
lxc-start: sync.c: __sync_wait: 51 invalid sequence number 1. expected 2
lxc-start: start.c: __lxc_start: 1088 failed to spawn 'lxc-one'
lxc-start: lxc_start.c: main: 345 The container failed to start.
2

Install libcap-dev using

apt-get install libcap-dev

Then, recompile the LXC.

  • NEVER BLINDLY RUN COMMANDS!!! While these are safe, can you explain what they do and how they solve the problem on-hand? – Kaz Wolfe Jan 18 '15 at 3:56
  • Arup's suggestion works for me, also it's supported here: mail-archive.com/lxc-users@lists.linuxcontainers.org/… – davide Oct 11 '15 at 15:07
  • Libcap implements the user-space interfaces to the POSIX 1003.1e capabilities available in Linux kernels. These capabilities are a partitioning of the all powerful root privilege into a set of distinct privileges. – Amila Kumaranayaka Feb 24 '17 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.