0

Is there a special driver I need to install or a cfg to edit?

Usually when I install Ubuntu on laptops it instantly supports the two-finger functions.

Ubuntu 14.04 LTS

2 Answers 2

1

Some touchpads simply do not support this. I have an HP DV9000 which is otherwise identical to a friend's DV9000 but their touchpads have different part numbers and only one of them supports two finger control. Simply put, if two finger scrolling is not supported in the mouse/touchpad area of the System Settings, then you have a laptop with a single-finger touchpad and there's not much you can do about it except to either plug in an external touchpad (or keyboard with touchpad as I did) or get rid of that laptop and get one with the type of touchpad you like.

0

Have you tried just going into system settings -> mouse to see if there's an option called "Enable two finger scrolling"? Sometimes I have to manually enable that setting after I install Ubuntu on a computer.

If that setting isn't listed, you could try installing dconf-editor and looking in there for the touchpad settings. But if you get to that point, let me know and I can tell you where to go inside dconf-editor.

EDIT

It's already enabled? That makes me think changing the setting in dconf-editor won't help either, but trying it won't hurt. I'm not sure how familiar you are with Terminal, so I'll write this so that even if you're completely new, it should be easy.

  1. Open up Terminal with ctrl+alt+t.
  2. Copy and paste the commands below. (ctrl+c and ctrl+SHIFT+v)
    (In Terminal, you have to paste with ctrl+SHIFT+v, not ctrl+v like usual. This is just how the Terminal has been designed in Linux/Ubuntu.)
    sudo apt-get update
    sudo apt-get upgrade -yr
    sudo apt-get install -yr dconf-editor
    dconf-editor
  3. Once the dconf-editor window is open, navigate through the 'tree' on the left side like this:
    org-->gnome-->settings-daemon-->peripherals-->touchpad
  4. Make sure that under scroll-method, two-finger-scrolling is enabled. You can click on the value to change it.
  5. If this doesn't work, try running dconf-editor as root:
    sudo dconf-editor
  6. Then try steps 3-4 again with the new window that opens up. The settings should take effect right away, but if not, try restarting the computer.

Like gyropyge said, touchpads sometimes are just odd. On my brother's laptop, I could enable two-finger scrolling on Windows but not Ubuntu. On my old laptop, it was the other way around.

1
  • That setting is enabled. What are the steps for dconf -editor? Jan 1, 2015 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.