3

I am a new Ubuntu user, and have been playing around with it with since installing it. I noticed that I have been getting a lot of eye strain due to the low refresh rate (of 50 or 60). I found this post about changing the refresh rate, but unfortunately, I can't seem to turn it up.

I have a BenQ XL2420T 120 Hz monitor. I have the NVIDIA proprietary drivers installed. CompizConfig Settings Manager showed a value of 50 for the Refresh Rate property under the Composite plugin, but changing this to 120 didn't have any effect. xrand displays the columns 60.0*+ 120.0 99.9 for my resolution, but when I try the xrand -r 120 or xrand -r 99.9 commands, it just says that the refresh rate is not available for the size.

I don't understand what's going on here. I assume that those three columns that xrand output are the current refresh rate, the maximum refresh rate, and... something else. So clearly it sees that 120 is supported - why does it then say that it's not available?

How do I get this to work? It's been so long since I've worked with such a low refresh rate and it's killing my eyes.

Thanks in advance.

5

I managed to fix this issue, so I'm posting the answer here in case anyone else has the same problem.

  1. According to someone on the internet, the NVIDIA drivers don't support xrandr (or at least not the current version). In order to change the resolution, I needed to use the "NVIDIA X Server Settings" GUI instead. The option is available on the "X SERVER Display Configuration" menu, under the "Resolution" setting. It defaults to "Auto" which apparently always uses 60 Hz. I needed to explicitly set my resolution and refresh rate, and apply it. Note that the first time I did this, I got a crash (from Compiz, I think?). I restarted my system and tried it again, and that time it worked. After changing this setting, xrandr displays 120 Hz as the current refresh rate.

  2. However, the above change isn't the full story. I could clearly see that 120 Hz was still not being used, as rapidly dragging windows around on my screen resulted in jerky and flickery movement. In order to fix this, I had to open up the "CompizConfig Settings Manager" GUI, navigate to the "Composite" plugin, and again set the refresh rate back to 120 Hz. I had already changed this earlier, but for some reason, it had changed itself back. I then disabled "Detect Refresh Rate" in order for it to hopefully keep my setting.

With the above steps implemented, my refresh rate has successfully been changed to 120 Hz. It's amazing going back to 120 Hz again after suffering 60 Hz. It is silky smooth, and my eyes are already feeling better. :)

  • Welcome to Ask Ubuntu! Thanks for coming back and explaining how you fixed your problem. That's great! We hope you'll stick around :) – Seth Dec 31 '14 at 20:23
1

I also had this problem and it took an aggravating 4 hours of work and no result. After like a month I decided to play around with the xrandr command some more. The result it didn't even accept xrandr -r 60. But it did accept xrandr -r 50. I checked my monitors osd and it said 60hz. After that I decided to try when it would break. Though for some reason I already achieved my initial goal at xrandr -r 51 as it now ran at 120hz. I still don't know what is causing this but my display finally runs at 120hz so I am really happy. Anyone who is having this issue should try some different rates to get it to work. I still don't get what is causing this but hey it works :).

  • It's nice that you could work things out for you. Could try to make it a bit more readable so other readers can learn from your experience? Just add some structure to the text and formatting to the code sections (with the <$> tool in the toolbar above the edit textarea). Also have a look at How to write a good answer. – David Foerster Feb 7 '15 at 0:16
0

I recently was fooling around with xrandr, trying to add new mode to get a 3200x1800 desktop at 60hz. This article helped me:

http://ubuntuforums.org/showthread.php?t=1112186

I used gtf to get the mode information for my desired setting, and then added it with xrandr

Note, I did not go through with putting the changes into xorg.conf

Maybe this will help you?

  • Thank you for your help. I managed to fix the problem, so I've posted a separate answer. While my solution wasn't the same as yours, your link still did help me, as one of the posters there mentioned using the nvidia-settings program, which got me on to the right track. Thanks! – Dan Dec 31 '14 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.