0

This question already has an answer here:

To begin with I am new in Ubuntu and I am trying to install Ubuntu 14.04 to my PC. I have a Sony Vaio VPCF24P1E. I have read many questions and answers about the same topic and I still cannot find a solution. The steps I tried are:

  1. Install Ubuntu to a USB -->Done //
  2. Create an undefined partition of my HD -->Done //
  3. Turn off fast boot in Windows 8 -->Done //
  4. Turn off secure boot --> <>

I tried to disable secure boot in bios but no choice of doing that was found. Then i tried from windows after Advanced Restart but there was no choice (tile for that wasnt there) for UEFI Firmware Settings. I am out of solutions... so any help would be appreciated.

marked as duplicate by Eric Carvalho, user68186, Charles Green, Evandro Silva, Fabby Jan 20 '15 at 12:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    I installed Ubuntu alongside Windows 8 without turning off Secure Boot and didn't encounter any issues. Are you sure that Secure Boot needs to be disabled for your install? – rob Dec 31 '14 at 18:05
  • Thanks for your reply Bob & Stephen! --UEFI is not supported in the restart options-- Did you installed it on Desktop or Laptop? Can you tell me how did you do that? I am asking because when I am trying to boot from USB (with linux) my laptop does nothing and just loads Windows 8. I tried to change booting order or pressing F11 but nothing happened. So I think by turning off Secure Boot it will solve my problem! Thanks in advance! – 5telio5 Jan 2 '15 at 11:25
0

The only way to install Ubuntu on uefi system from my experience is this:

disable fast boot, enble sata achi, enable usb boot, disable secure boot.

After that download and use RUFUS to make bootable USB, with gpt uefi partitioning, fat formatted.

P.S. My uefi on Lenovo Y580 have some bug, so to detect bootable USB I have to enter uefi at least twice to configure boot order. First time uefi just do not see usb.

0

You have done all the steps correctly. Good job.

To enter the BIOS in Sony Vaio, press the Assist key when the laptop is shut down. This will bring up a Menu where you can see an option to enter BIOS [F2]. In the BIOS, search for the option to Disable Secure Boot.

enter image description here

Then you can continue with the installation and welcome to the wonderful world of Linux!

  • Thank you for your reply. I followed what you said and DONE!!! I installed perfectly Ubuntu!! Thank you so much! – 5telio5 Jan 6 '15 at 16:55
  • Glad I could help. :) – Babbzzz Jan 6 '15 at 17:53
  • Hi @5telio5 if this or any answer has solved your question please consider accepting it by clicking the check-mark. This indicates to the wider community that you've found a solution and gives some reputation to both the answerer and yourself. There is no obligation to do this. – Babbzzz Jan 6 '15 at 20:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.