2

A couple days ago I moved my home directory to a new SSD I got. That was pretty painless and everything is working now, except one thing. Every time I boot up it says it found a problem on my disk (/dev/sdc) and allows me ignore, unmount, or manually fix it. I always choose ignore since everything's working for me. But last time I booted up I tried to fix it. I ran fdisk and that says:

Disk /dev/sdc doesn't contain a valid partition table.

How do I fix this?

If applicable, here's my /etc/fstab file:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc2 during installation
UUID=f766587d-5486-49fc-ba0c-48de358f38d7 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc3 during installation
UUID=973f8c23-0949-4c6c-8cd2-668cdf747859 none            swap    sw              0       0
# home folder
/dev/sdc    /media/neutron256gigssd     ext4    defaults    1   2
UUID=257a0481-1626-4f22-81ce-d5c853af1fb6   /home    ext4          nodev,nosuid       0       2

Edit: I've tried checking the drive in gparted, which didn't help. Also, the error I get on start up is "Serious errors were found while checking the disk for /home"

as requested, here is the output of

mount; sudo parted /dev/sdc print free

/dev/sdb2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sdc on /media/neutron256gigssd type ext4 (rw)
/dev/sdc on /home type ext4 (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
systemd on /sys/fs/cgroup/systemd type cgroup       (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=josh)
[sudo] password for josh: 
Model: ATA Corsair Neutron (scsi)
Disk /dev/sdc: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End    Size   File system  Flags
 1      0.00B  256GB  256GB  ext4
  • Why is your fstab trying to mount the whole disk /dev/sdc to /media/neutron256gigssd? What's the output of mount; sudo parted /dev/sdc print free? – Alaa Ali Jan 1 '15 at 1:49
  • I'm trying to mount the entire disk since I couldn't find another way to mount it. I'll put the output of that in my question. – BombSite_A Jan 1 '15 at 1:53
  • Hmm, that's strange. It says your partition table is type loop. Also, why are you mounting the disk to that folder under /media AND to /home? I'll post an answer with some steps and let's see if it works, but first, what's the output of sudo blkid /dev/sdc1? – Alaa Ali Jan 1 '15 at 2:14
  • `sudo blkid /dev/sdc1' outputs nothing. And I'm not sure why I did that actually, haha. I think I initially mounted it to /media to copy my data to it and get the UUID and stuff and then to /home once that was complete and never bothered to change it. You think that's what's causing it? – BombSite_A Jan 1 '15 at 2:16
  • Well yeah. Remove the line that's mounting it to /media/neutron256gigssd then restart and see if you don't get the error anymore. But otherwise your /home folder is working fine? Does the output of df -h /home say something like /dev/sdc and size 256G? – Alaa Ali Jan 1 '15 at 2:25
0

Your fstab file shows that you're mounting the drive to two different mount points. Generally, I think that doesn't work. If you really wanted to do that, you could create a symbolic link to the original mount point.

But since you don't want to do that, and you don't need the disk to be mounted under the /media folder anymore, remove this line from your fstab file:

/dev/sdc    /media/neutron256gigssd     ext4    defaults    1   2

Restart or execute the command mount -a for the changes to take effect. This solved your problem (discussed under the comments section).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.