4

According to some questions, this is how it's done:

sudo apt-get install language-pack-[cod] language-pack-gnome-[cod] language-pack-[cod]-base language-pack-gnome-[cod]-base 

Where [cod] is the language code, in my case I want to install japanese so I tried jap, jp, jpn, and none of these packages were found. I also tried zh for chinese but that didn't work either :(

3

Note: This answer is now outdated and breaks systems, e.g. Lubuntu 18.04.1 LTS on a Dell Latitude D620, such that opening Fcitx and clicking on the keyboard crashes the computer. Please pay attention to the dates and operating system for which this answer may be valid. (For example, the link in this answer leads to Lucid documentation, an OS which has now reached end of life.) If you accidentally follow this answer for a different Ubuntu version, you may need to uninstall QT4 and GTK3 packages. For example,

sudo apt purge fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-frontend-qt5 kde-config-fcitx

followed by

sudo apt autoremove

Try "ja"

sudo apt-get install language-pack-ja language-pack-gnome-ja language-pack-ja-base language-pack-gnome-ja-base

You might want to check out the language support metapackages as well.

Edit:

A convenient way to do the latter is to run:

sudo apt-get install $(check-language-support)
2
  • Ah, that was it, seems like the language codes are different? :\ – Shelby. S Dec 31 '14 at 16:33
  • I tried lots of advice to install Japanese fonts on my Ubuntu on Windows setup, and this is (almost) the only thing that actually worked (and both things were necessary). – Aaron Bramson Jul 24 '18 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.