4

I want to connect Ubuntu LTS via windows7 RDP. Is there any other settings these settings are not working.

https://community.hpcloud.com/article/using-windows-rdp-access-your-ubuntu-instance

6

You'll need xrdp together with x11vnc if you want remote access to your Unity desktop.

First, install xrdp and x11vnc:

apt-get install xrdp x11vnc

Then edit /etc/xrdp/xrdp.ini and make sure it contains at least the following:

[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=high
channel_code=1
max_bpp=24

[xrdp1]
name=Remote Desktop
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=5900

Restart xrdp for the changes to take effect:

/etc/init.d/xrdp restart

Now open up a terminal window (Ctrl+Alt+T) and set up a VNC password (you don't want to leave wide open access to your desktop from the internet):

x11vnc -usepw

You'll be prompted to set up a password, that will be used for RDP authentication.

The last step is to start x11vnc. There are tons of options that you can use, but here is an example to get you started (run this in the same terminal window you just opened):

x11vnc -rfbauth ~/.vnc/passwd -display WAIT:0 -reopen -nevershared -forever -wirecopyrect always -scrollcopyrect always -norepeat -1 -xkb -capslock -skip_keycodes 187,188 -bg -o ~/x11vnc.log &

The & at the end will leave x11vnc running the background, so you can close the terminal window and leave it running.

You'll need to add this command to your startup scripts if you want x11vnc to run automatically after a reboot.

9
  • Still not being connected. Dec 31 '14 at 13:54
  • You need to provide more information. Does the xrdp login screen show up? Is the firewall on the local machine configured to allow connections to port 3389? If you're connecting from the internet to a host behind a NAT router, is port forwarding set up correctly? Also, post the contents of x11vnc.log in your home directory.
    – ATAKAMA
    Dec 31 '14 at 14:00
  • Please post the log as a comment, not as an edit suggestion. Also, please answer the rest of the questions.
    – ATAKAMA
    Dec 31 '14 at 14:14
  • 31/12/2014 08:50:43 passing arg to libvncserver: -rfbauth 31/12/2014 08:50:43 passing arg to libvncserver: /root/.vnc/passwd 31/12/2014 08:50:43 passing arg to libvncserver: -nevershared 31/12/2014 08:50:43 x11vnc version: 0.9.12 lastmod: 2010-09-09 pid: 29028 31/12/2014 08:50:43 31/12/2014 08:50:43 wait_for_client: WAIT:0 31/12/2014 08:50:43 31/12/2014 08:50:43 initialize_screen: fb_depth/fb_bpp/fb_Bpl 24/32/2560 31/12/2014 08:50:43 31/12/2014 08:50:43 Autoprobing TCP port 31/12/2014 08:50:43 Autoprobing selected port 5900 31/12/2014 08:50:43 Listening also on IPv6 port 5900 (socket 4) Dec 31 '14 at 14:16
  • Windows remote desktop shows connection failed message even if turn off windows firewall. Dec 31 '14 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.