31

Every time I plug in my headphones, Ubuntu shows a popup box asking whether I've plugged in headphones, a headset, or a microphone.

How do I get it to stop doing this?

4
  • 1
    Please, can you provide a screenshot of what you have? Thanks. – ThunderBird Feb 7 '18 at 21:23
  • This behaviour seems to have changed in recent (17.10+) Ubuntu versions, quote " The dialog changed in Ubuntu 17.10. The behaviour is much friendlier now. " – Robert Riedl Feb 20 '18 at 12:20
  • Try reinstalling the audio drivers on your computer. You also can try before this to Open realtek, click the little folder on the top right hand side next to "Analog" and check the box that says "Enable Pop-UP. – AndrewRodgers Apr 12 '18 at 15:17
  • 1
    This is really annoying. HUGE STEP BACK. Not only Ubuntu team added this stupid popup, but they won't even provide a checkbox to get rid of it! This "user genocide" is not new to ubuntu, we still remember the times when they replaced Gnome with Unity. – Kostyantyn Aug 26 '20 at 7:07
6

I have the same pop-up in Ubuntu 16.04, whenever I plug in my headphones:

Audio Device Pop-Up box

Apparently, there was an option to disable it in the previous versions, mainly because of the changing hardware for headsets. Previously, there used to be different jacks for speakers and microphones, but today's machines have merged them into one. Different standards too cause problems in autodetection.

Have a read here: http://voices.canonical.com/david.henningsson/2014/03/07/headset-jacks-on-newer-laptops/

3

You can lie to Alsa by appending

options snd-hda-intel model=headset-mic

onto the end of /etc/modprobe.d/alsa-base.conf, followed by a reboot.

This works for XPS15 under Ubuntu 19.04 and 19.10 but it should also work for any Intel-based audio card.

2
  • It worked to my also. Ubuntu 20.04 Dell G3 3579. My processor is Intel – Guilherme Parreira Jul 29 '20 at 16:47
  • Looks nice, but isn't there a more dynamic way to do this ? e.g. restarting a service rather than rebooting ? – Balmipour Sep 22 '20 at 9:02
-1

In System Settings, an option to disable the pop up is available. Check the section Handling unknown audio jack devices of the Ubuntu Wiki.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.