1

A day ago I try to get my graphics driver for Geforce GT 755M SLI installed on my Lenovo Y510P laptop. I read and tried at least 6 type of installing most of them just ruin the resolution from 1920x1080 to 1024x768 or 800x600 and no way I could change that. Others make this message This system is running in low-graphics mode, also tried to fix it but then my laptop just show me a black screen with a flashing dash. I reinstalled the OS a few times, backup didn't solved the resolution problem. I am really new to this whole Linux system, I had Windows before. I would appreciate any type of help, thanks!

Edit: Now the resolution is okay. But now when I try to watch a video in HD it's like a 360p like the driver not changed anything, checked a full hd picture and it's so "pixely" on my screen.

And most of the times when I moving the mouse random parts of the screen are flashing.

For lspci | grep VGA

I get this:

01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 755M] (rev a1)

It's only shows one card from the two...

Tried to revert for nvidia 304, but after it just booted me to black screen needed to reinstall Ubuntu

1

I have running to this situation multiple times . Here is how I fixed it :

  1. go to Nvidia website and download the lastest version of GT 755M SLI driver(make sure that you have selected right with x64 or x32).
  2. then press ctrl+alt+F1 open console .

  3. purge your installed Nvidia driver before installation.

    sudo apt-get purge nvidia

  4. Remove Xorg.conf for the resolution fix

    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

  5. stop lighdm before driver installation (this is required)

    sudo service lighdm stop

  6. now go to your Nvidia driver file path and install it.

    cd path/to/file sudo chmod a+rwx Nvidia-xxxxxxxxxxx.run sudo ./Nvidia-xxxxxxxxxxxxx.run

  7. after installation ,reboot

    sudo reboot

Finally , Relax and You're Welcome

0

Based on my recent experience, there are significant bugs in the latest release of the 331 series nVidia drivers; I reverted to the 304 family using Driver Manager (Kubuntu) and doing so restored full functionality. You might try enabling the "edgers" PPA to try the 340 family drivers (you'll have to install that driver with apt-get or a package manager if it doesn't show up in Driver Manager).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.