0

Summary: I want to know how to change the permissions of my sound devices so that only my user can read and write to them. I thought this could be accomplished by chmod 0660 /dev/dsp* but /dev/dsp* does not exist.

System Info: Ubuntu 14.04.1 LTS (xubuntu)

Detailed Problem: I noticed that light locker stops my audio when it automatically logs me out after a certain duration of inactivity. I found an article that suggests I Add my user to the audio group (see: http://xubuntu.org/news/screen-locking-in-xubuntu-14-04/ ). I didn't know how to do that, so I found another instructional article saying I should also change the permissions of the sound devices so only audio users can read and write. It says I should execute chmod 0660 /dev/dsp* (see: http://www.maenad.net/geek/di8k-debian/node23.html ). However my system doesn't have /dev/dsp*. I want to know what the correct directory is for Ubuntu 14.04 so that I can properly change permissions as mentioned above.

  • 3
    Adding yourself to the audio group is easy: sudo adduser $USER audio – muru Dec 30 '14 at 21:18
  • I would use a group (audio probably) for the device and put yourself into that group. – Rinzwind Dec 30 '14 at 21:18
  • @muru Yes thank you, I should clarify though, I have already successfully added my user to the audio group. My problem rests in finding the correct location to chmod. – Daniel Dropik Dec 30 '14 at 21:20
  • 2
    You do not need chmod. You should not change anything in /dev/ – Rinzwind Dec 30 '14 at 21:20
  • 1
    Indeed, that's a rather old guide (11 years and counting). You'll find that sound devices on Ubuntu are all usually owned by audio: find /dev -group audio – muru Dec 30 '14 at 21:23
0

Did you check this one to know the device file. Taken from the man page of dsp.

OSS 4.0 (and later) will create audio devices under /dev/oss/ directory. For example /dev/oss/sblive0/pcm0 is the first audio device that belongs to the first Sound Blaster Live! or Audigy card in the system. These direct devices are used when an application needs to access specific audio device (instead of the default one).

   You  can use the ossinfo(1) utility with the -a option to get a list of
   the available audio devices in the system.
| improve this answer | |
  • 1
    Thanks for the info, I actually came across some references to OSS 4.0 during my initial search. However, I do not have oss listed in /dev/. I have searched for it using ls -lah /dev. – Daniel Dropik Dec 30 '14 at 21:25
  • 1
    That's because OSS is also old. Ubuntu uses PulseAudio. You might have some luck disabling PA and switching to ALSA, which is not that old, but I can't help you with that. – muru Dec 30 '14 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.