4

I have VirtualBox on Ubuntu 14.10 and some programs don't work on Wine, so I wanted to use a Windows XP SP3 ISO (for basic programs) and it gives me the error "FATAL: No bootable medium found! System halted." These are my settings for Storage: enter image description here

And here are my settings for system: enter image description here

How do I fix this?

1
  • Check to make sure that you selected Linux and Ubuntu when you're creating the virtual machine. I chose Windows and it gave me this exact error. – Pikamander2 Oct 2 '17 at 1:54
4

Seems like you have not a hard-drive... you can add one on Settings like here on my image (I have it in Catalan language, sorry)

How to add a hard-drive

If you have already one, just add a CD (at the left from add hard-drive button) and run VirtualBox machine again.

Edited:

Well, seeing your images, the only thing what I can think is when you run the virtual machine, press F2 to enter on boot menu, select the CD, key C and start the Windows XP installation, you should be able to install it.

PS: Be sure to make on general tab a type of machine Windows XP (32 bit).

13
  • Now you have the sufficient reputation to upload images :) – blkpws Dec 30 '14 at 20:36
  • Can you check the pictures now? I haven't solved the problem. – kprovost7314 Dec 30 '14 at 21:01
  • Okay, I edited my response. I'm sorry but I can't think about another problem. Your VirtualBox seems that is working well. – blkpws Dec 30 '14 at 21:21
  • Still not working.... – kprovost7314 Dec 30 '14 at 22:36
  • Wait, not it says "FATAL: Could not read from the boot medium! System halted" (Only when I press C) – kprovost7314 Dec 30 '14 at 22:38
2

The main reason this could be happening is because the ISO is not loaded. Other reasons why this may be happening is because the ISO may be corrupted, damaged, or not finished downloading. This is one of the problems with Google Chrome, it will say finished but not really finished and you get a partial ISO. Try downloading with Windows, or with Safari.

Ciao, Landon

1

It happens if you don't pay attention to the primary boot disk. When you choose ISO image, also expose the cd as primary. Also, there is the priority for boot in "System option". You can manage them by clicking a small arrow next to Boot order checkboxes.

Otherwise it won't see your ISO image while booting and you'll get this error:

FATAL: No bootable medium found! System halted.

0

I had the same problem trying to install a CentOS .iso in VirtualBox on a MacBook Pro. The mirror site I downloaded the image from did not have "DVD" in the filename and took hours to download. I started top level of the CentOS site, clicked on "Get CentOS" and clicked on the "DVD ISO" and downloaded from the nearest mirror site which took minutes to download. The original had "aarch64" in the filename and the new one I used had "x86_64". Long story longer, the .iso image you are using might not be a DVD .iso image. Don't know enough to know if there is a difference, but it worked for me! Also, I know this is an Ubuntu Q&A, but the issues might be similar.

0

I just had the same issue, but for me i needed to re-order my SATA optical drives with the windows iso as port 1, and the physical cd/dvd as port 2. then it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.