I have a 75 Mbit/s Wifi connection and the Wifi generally works great and fast. Although if I connect to any bluetooth device (e.g. some Audio device) the Wifi suddenly slows down significantly, but I still have a strong signal.

I am currently running Ubuntu 14.10 with Unity on a Dell Vostro V131

Is the bluetooth interfering with the Wifi, or is it a Hardware/Software problem?

If there are any outputs you need to see please let me know.

Thanks in advance!

| improve this question | | | | |
  • 1
    Do you have a combined Bluetooth/Networking card? Normally, as far as I know, Bluetooth and Wi-Fi signals do not interfere with each other. You might be experiencing lag due to a poor CPU, bottlenecking your connection speed. – waterlubber Dec 30 '14 at 17:15
  • I added the Computer to my original Post. Here are the Network cards: Realtek PCIe GBE Family Controller (10/100/1000MBit), Intel Centrino Wireless-N 1030 (b g n ), 3.0+HS Bluetooth, optional (Dell Wireless 5550 HSPA Mini Card), and it has an Intel Core i5-2410M 2.3 GHz, so I don't think the CPU is the bottleneck. – YumTum Dec 30 '14 at 17:25
  • 2
    I was doing research on Wikipedia, and according to it, "Because of this choice of frequency band, 802.11b and g equipment may occasionally suffer interference from microwave ovens, cordless telephones, and Bluetooth devices." Possibly your antennas are interfering with eachother. You may want to experiment with the positioning of the antennas, etc. I'm not an expert on the topic, but I thought I could provide some useful advice. – waterlubber Dec 30 '14 at 17:29
  • I tried it in different rooms with different devices, so its not depending on the position. And it only affects my laptop, my mobile still has a great wifi speed after connecting via bluetooth. Thanks for your help! – YumTum Dec 30 '14 at 17:32
  • 2
    I had the same issue on all of my computer and managed to fixe it using this thread : bugs.launchpad.net/ubuntu/+source/bluez/+bug/219057/comments/16 Good evening – user420128 Jun 14 '15 at 20:40

There is one thing that might help, and that is to disable bluetooth coexistence in the iwlwifi module

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi bt_coex_active=N

If it works, you can make it persistant with echo "options iwlwifi bt_coex_active=N" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

If it causes problems, just sudo modprobe -r iwlwifi

sudo modprobe iwlwifi
| improve this answer | | | | |
  • I tried it only with the result that network-manager couldn't connect to any wifi. Any clues why that could be the case? – YumTum Dec 30 '14 at 22:53
  • Since the default is bt_coex_active=Y the sudo modprobe -r iwlwifi sudo modprobe iwlwifi is all that is needed unless the echo "options iwlwifi bt_coex_active=N" | sudo tee -a /etc/modprobe.d/iwlwifi.conf command is used, without that command being used, even a reboot will reset things back to normal – Jeremy31 Dec 30 '14 at 22:54
  • +1 for this answer. I had exactly the same problem using the same laptop model with Ubuntu 15.04 and this solution worked for me. Note: a restart was essential in my case, i.e. I had to append the options line to /etc/modprobe.d/iwlwifi.conf and then restart the machine. Without a reboot I got the same result as @YumTum, i.e. lack of Wi-Fi connectivity. – Kempniu May 3 '15 at 20:09
  • Seems to have fixed it for me in 16.04 as well – Izkata Jan 29 '17 at 22:46
  • This also fixed broken wifi with enabled bluetooth on my ASUS UX501V. – edam Feb 13 '18 at 16:39

Try hooking your wifi or bluetooth adapter into a USB extension cable and running that away from the other adapter.

I have a Trendnet TBW-105UB bluetooth adapter and a D-Link Dwa 552 wifi adapter and was experiencing this problem until I simply moved the two apart.

Surprisingly, problem resolved.

Credit to @waterlubber for this simple fix. I would have upvoted his comment but don't have the reputation.

| improve this answer | | | | |
  • Thanks a lot! When nothing worked for me, your solution had worked like a charm! – user1896653 Jul 4 '16 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.