0

Today I tried to connect an external monitor to my laptop, running Ubuntu 14.04, for the first time. The connection is made with an HDMI to DVI cable (Laptop has the HDMI, Monitor the DVI Port), the same setup worked without problems when I had Win7 installed. My laptop has a proper graphics card and the Intel HD Graphics on board stuff.

When I just use the internal OR the external monitor, each of them is working perfectly. But if I use both of them, it doesn't. My laptop has a resolution of 1920*1080 and the external one has 1680*1050

So now to the actual problem: The main Monitor works fine (so if I use the internal as main, that one works fine, but the external doesn't, if I use the external monitor as main monitor, the internal breaks (so I guess it's a software/OS related problem and not a problem with the hardware of my external monitor)). The problem is: Moving the mouse on the second monitor has extreme lags, but even worse the image doesn't begin at the border of the image, but somewhere in between, then a black gap and the other half of it. I know that sounds confusing, so here a few images, maybe they are better understandable.

Images I don't have enough reputation for inline images yet :( As you can see on the first and second, each of the monitors is working fine, when only one monitor is active. On the third you see the problem about the gap, that It's ripping the display apart somehow on the right monitor. The fourth is just the second monitor with the problem.

Edit: I tried all available graphics drivers (Drivers)

If you need any further information, please let me know.

1

I found out, that on my system two X display managers where installed: gdm and lightdm. The default one was lightdm. After setting the one to gdm I can now use both monitors without any problem!

To change the default simply run sudo dpkg-reconfigure lightdm.

I hope this helps if someone has the same problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.