0

I'm running the latest version of ubuntu 64 bit (14.04) on a computer that is only a few weeks old. I can't install wine with the software center or the command line. I have tried every simple fix like manually adding the repository and upgrading which doesn't help at all. I have also tried different variations of the install command like apt-get install wine1.6:amd64, apt-get install wine1.6 -f, etc. I have tried installing a different version of wine also to no avail. This might look like a question with lots of duplicates but it isn't, I have looked at all the similar ones and their solutions are either non existent or non functional in my case.

I get the following error message with the software center:

The following packages have unmet dependencies:
wine1.6: Depends: wine1.6-amd64 (= 1:1.6.2-0ubuntu4) but 1:1.6.2-0ubuntu4 is to be installed
         Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu4) but it is a virtual package

And the following error if I try using the command line:

The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

All the variations of the install command give me similar errors.

0

Have you tried using Synaptic or Aptitude? Should be able to search for & install specific packages from there, and I read aptitude "tries harder" when confronted with some errors.

Did you search for the "held broken packages" solutions? Tried dpkg --get-selections | grep hold and un-hold or remove them? Unable to correct problems, you have held broken packages

I'd also guess your repositories are a little messed up, wine's in the standard repos (main, restricted, universe, multiverse, etc) & shouldn't need anything special. See https://help.ubuntu.com/community/Repositories/Ubuntu or the section from this answer "Restoring the default Ubuntu sources.list"

  • I tried using aptitude and it doesn't do the job either. I can't use synaptics because it claims that in order to install wine I first have to uninstall all of my programs including ones required to keep my computer running. – user363013 Dec 31 '14 at 16:39
0

Well as it turns out this issue was not fixable. At least not by using any method that I found for fixing dependencies. I reinstalled ubuntu and it is now installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.