6

I have a small Acer Revo PC with Ubuntu 14.10 that I'm configuring to run as a portable media center.

I'm trying to set it up as a WiFi access point so that I can control XBMC/Kodi with Android devices via an app. This works fine so far.

However, I'm having trouble with the WiFi being soft blocked by rfkill on every startup.

  • I tried unblocking it in /etc/rc.local (rfkill unblock wifi) but this doesn't work. Whatever is causing rfkill to block WiFi probably happens after rc.local is finished running.
  • If I SSH into the PC fast enough after a reboot, I can see that WiFi actually works for a couple of seconds and then gets blocked. I can see the network on my smartphone as well, but it disappears shortly after showing up.
  • I found the file that supposedly stores the rfkill state: /var/lib/rfkill/saved-state. Changing the line to phy0 0 or phy0 1 doesn't solve the problem. Also the file doesn't seem to change at all, so whatever stores the state doesn't work.
  • I tried removing the upstart scripts for rfkill (/etc/init/rfkill-[re]store) - no improvement.

What worked for me was the following line in rc.local:

sh -c "sleep 10 && rfkill unblock wifi" &

But this is a crappy workaround, I have to disable the AP and DHCP services from auto-starting and start them "manually" in rc.local after unblocking WiFi.

What causes rfkill to block things at startup? How do I disable this?

  • @adam-monsen Do you have exactly same setup? 14.10 has reached EOL and not supported any more in Ask Ubuntu. Could you put a comment thing that are different from OP case. – user.dz May 14 at 21:56
  • No, I don't. Yeah, I was worried this question was too old. Just seeking a good resolution / workaround. Here's the exact problem I hit today: askubuntu.com/questions/1143233/… – Adam Monsen May 14 at 22:00
0

I was just having this problem and nmcli r wifi on solved it. NetworkManager was killing the wifi after startup finished which is why startup script solutions didn't work for me.

  • this didn't work for me – Adam Monsen May 15 at 19:52
0
+50

You have to blacklist the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf

add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.

Or if you like one-line:

echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf

Other methods:

"Soft blocked" means "blocked by software". A faulty driver or other kernel module can lead to connectivity loss.

Some methods to get WiFi working are described on help.ubuntu.com/

There is also a Launchpad question on this issue: answers.launchpad.net

You can also try a specify device like

rfkill unblock bluetooth
  • Thank you! @M3L, any chance you can confirm this answer? – Adam Monsen May 20 at 5:14
  • Unfortunately, no - it's been 5 years since I posted this, I don't have that setup any more :/ – M3L May 22 at 7:18
  • Well @AdamMonsen did it work for you since M3L can't confirm , please check it out and the bounty :P – Nishanth R May 22 at 8:52
  • I'll give the bounty just for the effort and additional attention to this question. I also have no way to confirm. – Adam Monsen May 22 at 13:40
  • Thank you for the bounty . It would be great if could confirm the answer as well. – Nishanth R May 23 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.