I've a fresh installation of Ubuntu 14.10 desktop. I downloaded it yesterday. It has been installed correctly.

I've added a repository and now when I enter sudo apt-get update it gives following errors:

Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic InRelease
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/main Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/main Translation-en
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/restricted Translation-en_US
Ign cdrom://Ubuntu 14.10 _Utopic Unicorn_ - Release i386 (20141022.1) utopic/restricted Translation-en
Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic InRelease          

Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic-updates InRelease  

Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic-backports InRelease

Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic Release.gpg        
  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic-updates Release.gpg
  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
Err http://pk.archive.ubuntu.com|security.ubuntu.com utopic-backports Release.gpg
  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
Ign http://archive.canonical.com utopic InRelease                              
Ign http://ppa.launchpad.net utopic InRelease                                  
Ign http://extras.ubuntu.com utopic InRelease                                  
Hit http://archive.canonical.com utopic Release.gpg                            
Ign http://ppa.launchpad.net utopic Release.gpg                               
Hit http://extras.ubuntu.com utopic Release.gpg                      
Ign http://us.archive.ubuntu.com utopic-security InRelease           
Hit http://archive.canonical.com utopic Release                                
Ign http://ppa.launchpad.net utopic Release                                    
Hit http://extras.ubuntu.com utopic Release                                    
Ign http://us.archive.ubuntu.com utopic InRelease                              
Hit http://extras.ubuntu.com utopic/main Sources                     
Ign http://us.archive.ubuntu.com utopic-backports InRelease                    
Hit http://extras.ubuntu.com utopic/main i386 Packages               
Ign http://us.archive.ubuntu.com utopic-proposed InRelease                     
Hit http://archive.canonical.com utopic/partner Sources                        
Ign http://us.archive.ubuntu.com utopic-updates InRelease                      
Hit http://archive.canonical.com utopic/partner i386 Packages                  
Hit http://us.archive.ubuntu.com utopic-security Release.gpg                   
Hit http://archive.canonical.com utopic/partner Translation-en                 
Hit http://us.archive.ubuntu.com utopic Release.gpg                   
Hit http://us.archive.ubuntu.com utopic-backports Release.gpg         
Hit http://us.archive.ubuntu.com utopic-proposed Release.gpg
Hit http://us.archive.ubuntu.com utopic-updates Release.gpg
Ign http://extras.ubuntu.com utopic/main Translation-en_US
Ign http://extras.ubuntu.com utopic/main Translation-en
Hit http://us.archive.ubuntu.com utopic-security Release
Hit http://us.archive.ubuntu.com utopic Release                        
Hit http://us.archive.ubuntu.com utopic-backports Release             
Hit http://us.archive.ubuntu.com utopic-proposed Release               
Err http://ppa.launchpad.net utopic/main Sources                      
  404  Not Found
Hit http://us.archive.ubuntu.com utopic-updates Release
Err http://ppa.launchpad.net utopic/main i386 Packages                 
  404  Not Found
Ign http://ppa.launchpad.net utopic/main Translation-en_US             
Ign http://ppa.launchpad.net utopic/main Translation-en
Hit http://us.archive.ubuntu.com utopic-security/main Sources                  
Hit http://us.archive.ubuntu.com utopic-security/restricted Sources
Hit http://us.archive.ubuntu.com utopic-security/universe Sources
Hit http://us.archive.ubuntu.com utopic-security/multiverse Sources
Hit http://us.archive.ubuntu.com utopic-security/main i386 Packages
Hit http://us.archive.ubuntu.com utopic-security/restricted i386 Packages
Hit http://us.archive.ubuntu.com utopic-security/universe i386 Packages
Hit http://us.archive.ubuntu.com utopic-security/multiverse i386 Packages
Hit http://us.archive.ubuntu.com utopic-security/main Translation-en
Hit http://us.archive.ubuntu.com utopic-security/multiverse Translation-en
Hit http://us.archive.ubuntu.com utopic-security/restricted Translation-en
Hit http://us.archive.ubuntu.com utopic-security/universe Translation-en
Hit http://us.archive.ubuntu.com utopic/main i386 Packages
Hit http://us.archive.ubuntu.com utopic/universe i386 Packages
Hit http://us.archive.ubuntu.com utopic/restricted i386 Packages
Hit http://us.archive.ubuntu.com utopic/multiverse i386 Packages
Hit http://us.archive.ubuntu.com utopic/main Translation-en
Hit http://us.archive.ubuntu.com utopic/multiverse Translation-en              
Hit http://us.archive.ubuntu.com utopic/restricted Translation-en              
Hit http://us.archive.ubuntu.com utopic/universe Translation-en                
Hit http://us.archive.ubuntu.com utopic-backports/main i386 Packages           
Hit http://us.archive.ubuntu.com utopic-backports/universe i386 Packages       
Hit http://us.archive.ubuntu.com utopic-backports/multiverse i386 Packages     
Hit http://us.archive.ubuntu.com utopic-backports/restricted i386 Packages     
Hit http://us.archive.ubuntu.com utopic-backports/main Translation-en          
Hit http://us.archive.ubuntu.com utopic-backports/multiverse Translation-en    
Hit http://us.archive.ubuntu.com utopic-backports/restricted Translation-en    
Hit http://us.archive.ubuntu.com utopic-backports/universe Translation-en      
Hit http://us.archive.ubuntu.com utopic-proposed/main i386 Packages            
Hit http://us.archive.ubuntu.com utopic-proposed/universe i386 Packages        
Hit http://us.archive.ubuntu.com utopic-proposed/multiverse i386 Packages      
Hit http://us.archive.ubuntu.com utopic-proposed/restricted i386 Packages      
Hit http://us.archive.ubuntu.com utopic-proposed/main Translation-en           
Hit http://us.archive.ubuntu.com utopic-proposed/multiverse Translation-en     
Hit http://us.archive.ubuntu.com utopic-proposed/restricted Translation-en     
Hit http://us.archive.ubuntu.com utopic-proposed/universe Translation-en       
Hit http://us.archive.ubuntu.com utopic-updates/main i386 Packages             
Hit http://us.archive.ubuntu.com utopic-updates/universe i386 Packages         
Hit http://us.archive.ubuntu.com utopic-updates/multiverse i386 Packages       
Hit http://us.archive.ubuntu.com utopic-updates/restricted i386 Packages       
Hit http://us.archive.ubuntu.com utopic-updates/main Translation-en            
Hit http://us.archive.ubuntu.com utopic-updates/multiverse Translation-en      
Hit http://us.archive.ubuntu.com utopic-updates/restricted Translation-en      
Hit http://us.archive.ubuntu.com utopic-updates/universe Translation-en        
Reading package lists... Done                                                  
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic/InRelease  
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic-updates/InRelease  
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic-backports/InRelease  
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic/Release.gpg  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic-updates/Release.gpg  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
W: Failed to fetch http://pk.archive.ubuntu.com|security.ubuntu.com/ubuntu/dists/utopic-backports/Release.gpg  Could not resolve 'pk.archive.ubuntu.com|security.ubuntu.com'
W: Failed to fetch http://ppa.launchpad.net/plushuang-tw/uget-stable/ubuntu/dists/utopic/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/plushuang-tw/uget-stable/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found
W: Some index files failed to download. They have been ignored, or old ones used instead.

I've read a lot of questions and tried all of them one by one. But its still causing the problem. I've checked all of the options in Software and Updates and also tried different servers. It's causing the same problem

  • there are many solution available on the Internet, but they are for older version of Ubuntu. I couldn't find any solution for 14.10 :(. – arximughal Dec 29 '14 at 18:59
  • It's a "could not resolve" error, thus one which is purely client side. Check your DNS settings. – muru Dec 29 '14 at 19:38
up vote 1 down vote accepted

I'm not sure if there should be a pipe character | in the middle of your ubuntu server name... that's not just how the error message looks is it?

Try checking your software repositories, try different mirrors perhaps. This help page should help https://help.ubuntu.com/community/Repositories/Ubuntu

And I tried connecting to http://pk.archive.ubuntu.com and it just hangs, maybe it's just down.

  • the problem is only with pk.archive.ubuntu.com, i think its down now... US server is working fine for me now. – arximughal Dec 30 '14 at 19:29
  • From @Shalini, posted as answer: The accepted post has a link to Ubuntu's help on repositories- help.ubuntu.com/community/Repositories/Ubuntu. What specifically helped me from there after poking around for a while was to go to Software & Updates, under the Ubuntu Software Tab select Other and allow the system to select the best server for the downloads. – Volker Siegel Jan 15 '16 at 0:54

I have take this from Digital Ocean website :

Ubuntu 14.10 (Utopic Unicorn) reached "End of Life" on July 23, 2015 and is no longer supported. Ubuntu has recently remove it from their official mirrors. If you still require the Apt repositories for it, you'll need to edit your /etc/apt/source.list to point to:

http://old-releases.ubuntu.com/

We've also set up a mirror for it at:

http://mirrors.digitalocean.com/ubuntu-old

Though you are strongly encouraged to upgrade to a more recent release. Security updates are no longer provided for any packages in 14.10. We are providing that repository as a convenience and temporary work around for those who haven't upgraded to a supported release yet.

This worked for me.

  • 1
    At the time that the question was asked, and answered, Ubuntu 14.10 was not at end-of-life. Please note that the accepted answer dated Dec 29, 2014 apparently solved the users issue. – Charles Green Nov 20 '15 at 4:20

You are most possibly behind a physical / network firewall or some other network security device on which http/https proxy or few website categories are blocked or a rare chance but port 80/443/8080 are booked

  • 1
    I don't think so... because only pk.archive.ubuntu.com was not working fine. All other servers are pretty much okay. May be it was down for Maintenance or some other reason. – arximughal Jan 1 '15 at 12:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.