1

Can anyone help? Installed like here:

How to install SQL Developer on Ubuntu 14.04?

If I run:

sudo sqldeveloper

it starts and runs properly but if I run:

sqldeveloper

It wont start with any other error shown.

Are there missing rights for Sqldeveloper or Java. Where and how do I set them.

Any help appreciated, I am a Ubuntu noob.

Where do I find error logs?

Thank you...

  • Do you have a (hidden) "$HOME/.sqldeveloper" directory? if so, what are its ownership and permissions? – steeldriver Dec 29 '14 at 19:27
  • yes it is hidden: drwxr-xr-x 3 root root 4096 Dez 29 15:00 .sqldeveloper – user1786641 Dec 29 '14 at 20:26
  • 1
    thank you sudo changemod 777 .sqldeveloper worked although do not really understand what this directory is for and why it is not set properly – user1786641 Dec 29 '14 at 20:34
  • You should have changed the ownership not the permission bits - please see my answer below – steeldriver Dec 29 '14 at 20:45
4

Likely what happened is you ran sqldeveloper one time using sudo, which caused the configuration directory $HOME/.sqldeveloper to get owned by root. If so, you should be able to fix it by re-taking ownership of the directory, i.e.

sudo chown -R $USER:$USER ~/.sqldeveloper

or by simply deleting the directory

rm -rf ~/.sqldeveloper
| improve this answer | |
  • This should be chown, not chmod – kskyriacou Dec 19 '17 at 9:02
0

If we need to run sqldeveloper without sudo we need to run command in terminal

sudo chown -R $USER:$USER ~/.sqldeveloper
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.