0

1) The Yamanha MCR-B142 mini-HiFi has Bluetooth for streaming audio. I can successfully connect to it from Ubuntu 14.04 LTS and the device appears in the Bluetooth connections.

bt-device -l

Added devices: MCR-B142 Yamaha (00:1F:47:03:12:B5)

However, it does not appear in the audio output options, so I can't choose it as output!

Can anyone help me?

2) I am using a Conceptronic Bluetooth Nano adapter v4. On the manufacturer says this: If you want more advanced Bluetooth features, like audio streaming (A2DP) or connections to multiple Bluetooth devices at the same time, you need to install an additional Bluetooth stack (not included) which covers these features.

So, any ideas how to enable A2DP in Ubuntu 14.04?

3) I updated the blueman to: 1.23-git201403102151-1ubuntu1. Problem remains.

4) I edited /etc/bluetooth/audio.conf
4.a) to remove Socket from Enable
4.b) to enalbe [A2DP]

SBCSources=1
MPEG12Sources=0
Restarted
service bluetooth restart
No changes.

5) Doing: pactl list cards short

It does not show my bluetooth device in the list. This is for sure a problem.

6) I discovered that removing the socket (4.a) in the audio.conf disabled my BT connection the the Yamaha.

7) I did not had installed this, so i did it:

7.a) aptitude install pulseaudio-module-bluetooth

7.b) then i run this: pactl load-module module-bluetooth-discover and returns 23 (fortunately it was not 42!)

7.c) then i restart the BT service and reconnect to the Yamaha. And for the first time it appear a popup window at the bottom saying that i successfully connect to the Yamaha.

7.d) It appears the BT assistant and step-by-step i tell to connect using A2DP Sink (send audio) but it fails. It says it was added but the connection failed.

enter image description here

enter image description here

8) I found this bug report: https://bugs.launchpad.net/ubuntu/+bug/1283003

9) Now it appears: pactl list cards short

0 alsa_card.usb-Logitech_Logitech_Wireless_Headset_000D44E1B78A-00-Headset module-alsa-card.c

1 alsa_card.pci-0000_00_1b.0 module-alsa-card.c

5 bluez_card.00_1F_47_03_12_B5 module-bluetooth-device.c

but doing

pactl set-card-profile 5 a2dp Falha: Erro de entrada/saída

problem remains. something is still missing!

10) executing pavucontrol, in the config, the Yamaha appears but cannot connect. enter image description here

  • Welcome to AskUbuntu! ;-) Next time, please use your [Shift] key for correct CaPiTaLiSaTiOn! :-) – Fabby Dec 29 '14 at 13:04
  • HiFi is High Fidelidty. An very old term from the 80th. – kaf Dec 29 '14 at 22:08
0

After a long journey i managed to make it work. It is some kind of bugs in 14.04. After trying a lot the comment 15 in the bug: https://bugs.launchpad.net/ubuntu/+bug/1283003

solved the problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.