0

Maybe a couple months ago, I was attempting to push my project to Github when I encountered the following error:

fatal: unable to access 'https://github.com/choct155/TEL.git/': gnutls_handshake() failed: A TLS packet with unexpected length was received.

It seemed out of the blue, but it was probably caused by an update. After some digging, I came across the solution presented here, which essentially advised me to compile git against OpenSSL instead of GNUTLS. I did so, and all was right with the world.

I have just encountered the same error again. I went back to check my control file, and GNUTLS is nowhere to be found (I had replaced such instances with OpenSSL as prescribed). Can anyone advise me on where to look for the call that still seeks to use GNUTLS instead of OpenSSL? Is something else going on here?

I should also note that while inspecting my OpenSSL install, I received a warning suggesting that my config file could not be opened. This is presumably because the path cited does not exist. I have never called OpenSSL directly before (as may be obvious, I am quite ignorant in this area), so I cannot speak to whether or not this issue correlates with the GNUTLS business. If you think it is related, and/or just feel like sharing which environmental variable (I presume) must be modified so that OpenSSL can find the config file, please enlighten me.

NOTE: This appears to be a Github related issue, insofar as I was able to commit just fine. The log files serve as evidence of that, and there was no error. This fits with my intuition since the commit is local and would therefore have no need to deal with the capabilities of GNUTLS and OpenSSL to the best of my knowledge. Nevertheless, feel free to adjust my worldview.

closed as off-topic by Seth Jan 3 '15 at 3:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you sure there's nothing interfering with your connection? All the other users who use git with whatever default library it uses on Ubuntu have it working fine. – muru Jan 3 '15 at 2:18
  • No, actually, I am not. I tried it three days in a row and got nothing. I did a sanity check in response to your comment, and it worked. Apparently it was a temporary problem with Github. – Marvin Ward Jr Jan 3 '15 at 2:41
0

Evidently, it had nothing to do with what I was doing. I tried it again a while later and Github gave me no beef. In other words, there was a temporary issue with Github.

Not the answer you're looking for? Browse other questions tagged or ask your own question.