I just installed gnome by typing sudo apt-get install gnome-shell, and used gdm as login shell and my PC can't boot. It stayed in purple screen with Ubuntu logo! What can I do?


There is a way to apply the full update to Ubuntu: When you restart your computer and you think the booting process is done, press Ctrl+Alt+F1. You will be prompted for your username in text mode.

Log in with your username and password and make sure you have an Internet connection (e.g. ping google.com). If your WiFi isn't working, connect your computer to the router using an ethernet cable.

You can then simply type sudo apt-get update and your machine will download and install the missing packages. Restart your computer with sudo shutdown -r now and after rebooting, Gnome should be working just fine.

| improve this answer | |
  • Thx! Thats what I need! – leighton Dec 29 '14 at 12:39

After installing Gnome, try to purge the default settings using this command :

sudo apt-get purge ubuntu-default-settings

If the problem persists, remove the unwanted packages from Ubuntu using the below command and check:

sudo apt-get autoremove
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.