0

As the title suggests, I have tried everything but cannot see my Desktop 14.04 Ubuntu Gnome box from my laptop running the same distro, and vice versa. However, I CAN see my laptop samba shares from my Android phone using ES File Explorer.

Please do not suggest NFS or SSH or SFTP or SSHFS, as I have windows devices that occasionally connect, and I would rather get this thing up and running using Samba.

I should also mention that the router I use is a D Link DSL-2750 U and I can access the internet on both eth0 and wlan0. The problem arises when I try to ping the laptop locally (192.168.--) It fails when I do it from the desktop, and vice versa.

So basically my ethernet-connected desktop cannot see/ping my laptop, but my phone which is on the same wireless network as my desktop can.

I've tried everything I can including configuring the router, and going to factory settings. But I cannot for the life of me seem to fix this seemingly silly problem.

ANY help would be appreciated.

  • have you tried editing /etc/samba/smb.conf – Rohit Karadkar Dec 29 '14 at 8:53
  • I have, I've changed Samba settings on both ends a million times. I think the problem is with my hardware (router) or the software configuration that controls it. ES can access my laptop over WiFi, after all. – David de Lima Dec 29 '14 at 8:58
0

Try the below command and check whether you are able to configure samba,

sudo apt-get install system-config-samba
  • Hi! I did this. I'm beginning to think it's because my laptop is on WiFi and my desktop uses LAN. Because when I reset my Samba file on both laptop and PC, and connected both to the same router using LAN cables, they found each other. – David de Lima Dec 29 '14 at 10:25
  • Interestingly, my WiFi and LAN are on the same subnet, 192.168.0.50 onwards. The PC uses a MAC-reserved .50 address and the laptop has a .51 MAC-reserved address. My router does not allow using a different subnet for WiFi and LAN so I guess there's no way of fixing this. (IF a subnet-related fix were possible) – David de Lima Dec 29 '14 at 10:28
  • Here is my nmap result when I try to find my LAN connected desktop from my WLAN connected laptop. nmap 192.168.0.50 -Pn Starting Nmap 6.40 ( nmap.org ) at 2014-12-30 10:04 IST Nmap scan report for DFAIENCE (192.168.0.50) Host is up (0.082s latency). All 1000 scanned ports on ******** (192.168.0.50) are filtered Nmap done: 1 IP address (1 host up) scanned in 14.05 seconds – David de Lima Dec 30 '14 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.