Many of my UI elements become completely unresponsive. This happens in both Unity and GNOME Classic.

There are lot's of examples of this, but usually only some of the UI elements are unresponsive (e.g., I can't move a window, but I can click a menu somewhere else). The system is not lagging, the UI simply doesn't work. Sometimes I can get it to work by doing something unrelated (e.g., closing one window with Alt-F4 might allow me to move another frozen window).

This begins to happen immediately after I login. The behavior is repeatable, but there are so many UI elements that turn on and off that it can get very unpredictable.

I can usually press super to get the dash and Alt-F2 to get a command prompt. Also Alt-Shift-T seems to usually work to bring up a working Terminal (at least one that accepts commands, even if I can't move the window).

Does anyone have any ideas on what might be causing this? The behavior is highly unpredictable and extremely frustrating. I should note that key commands don't always work, even though they seem to in my examples. So I don't think it's just a mouse issue.

Thanks for any help.

  • Distro 11.04. Update Manager has no available updates for my system, so I assume I'm up to date.

  • Someone on launchpad suggested checking other accounts. In fact, making a new user and logging into that account, fixes the problem there and on my original account. Deleting the user makes the problem come back.

  • There's no change when I add the edd=on parameter on boot.

Also, I have to login to the new user before the problem stops on my usual user. This works as a temporary solution, although I'd really prefer to know what's going on (now I'm really confused). Also, I don't particularly want a second account if it's unnecessary.

Does anyone know what's causing the problem and making it come back when I delete the second account?

System info:

  • CPU: Intel Core i7 950
  • RAM: 8GB
  • GPU: nVidia GTX460 SE
  • Motherboard: Asus Sabertooth X58
  • Free Disk Space: 650 GB (64%) (two 2GB drives which are in a RAID 1 array)

Some other things I've tried are:

  • unity --reset
  • gconftool-2 --recursive-unset /apps/compiz-1
  • rm -rf .compiz .gnome .gnome2 .gnome2_private .gconf .gconfd .metacity

Also, I've discovered that having another user account is not enough. If I restart or even suspend my system, I need to login to the other account first before my own.

Also also, the unity --reset command segfaults when I run it through a tty. The line in the syslog concerning it is

Aug 14 11:26:43 Ubuntu-Desktop kernel: [ 217.921661] compiz[2539]: segfault at 58 ip 00007f674f345c51 sp 00007fffdfc43508 error 4 in libnvidia-glcore.so.270.41.06[7f674e3b3000+144e000]

I don't know if that will be helpful or not, but I thought it was weird.

I seem to have the same problem as poster #9 here. That is, I have the nvidia advanced graphics drivers installed, but the additional drivers pane says they aren't in use. I'm confused by this though, since the driver description says they're needed to run Unity. So either the description is wrong, or they are indeed in use. I still don't know if this is related to my current issue, particularly because I didn't change the drivers at all, and the same configuration exists on the new user account where things are fine.

Edit: I deleted a compiz-1 folder from ~/.config/ to no avail. There was no compiz folder there.

I don't think the nvidia issue is related. I've updated my graphics drivers to version 280.13, which is the latest from nvidia. On fossfreedom's suggestion I uninstalled those and installed the 173 drivers despite not supporting my graphics card. Predictably, I got no graphics and used single user mode to update my graphics again.

More pressingly, I've discovered that the secondary user doesn't solve the problem as I previously thought. The first user to log in (no matter which user it is) has the issue. The second user to log in fixes the problem for both users. Previously I had always logged into my own account and then logged into another, so I never noticed this.

This new development means that I can't carry out my previous plan of switching to a new user account. At this point, I'm pretty close to reinstalling. I have another harddrive in the mail that will be large enough to back up all my data completely.

But please, if anyone has any more ideas, tell me. I don't really want to reinstall if I don't need to do so.


I would consider doing a memtest and maybe a badblocks scan on your drive. The processor and memory are what draw your desktop or GUI items. Therefore I'd rule those out before we start pionting fingers at your desktop managers. Since both Gnome and Unity are acting up I find hardware a much more likely factor.

Sorry for posting an answer, but I do not have the ability to post comments yet.

Anyway, there is a memtest86+ test on any Ubuntu install cd or usb drive. I'd go with that first.


Seems like migrating to a new user account would be the best test as of right now. Something could just be corrupt from install and reverting when you delete the new user, I don't really know. But you can try this:

usermod -m -d /home/jerry -l jerry tom
### gone ###
ls /home/tom
### as it moved to ###
ls /home/jerry

This command gets rid of the user "tom" and moves everything to the user "jerry". The ls commands are just to double check your work, listing the new available directory, and the first one should give you an error as it no longer exists.

source: http://www.cyberciti.biz/faq/ubuntu-linux-howto-rename-user-account/

Hopefully if you move everything from your current account to a new one, you can have just one account without all the problems.

  • Okay, I finally found time to do a badblocks and memory test, both of which were fine and didn't solve the issue. I also found that booting from a Live CD was fine. Do you have anything else I can try? – Kris Harper Aug 13 '11 at 13:13
  • Well sir, now that your question is completely revised I am a bit stumped myself. I have also accumulated points to where I can comment now, or maybe just b/c it's my own post. I'm going to edit my answer with some information on changing user accounts and maybe that'll help you out of your current pickle. – Kheldar Aug 14 '11 at 18:07
  • Yep, this is basically what I've ended up doing. I'm going just copy over my data though (docs, music, .vimrc, etc.) rather than use usermod, because I'm afraid there's some corrupt setting somewhere that's causing this. Also, I don't know how the usermod command works, but I don't have enough diskspace to make a complete copy of my home directory, so that's a concern as well. Thanks for the input though. Hopefully this will work out. – Kris Harper Aug 14 '11 at 19:19
  • I hope so too, good luck. If that doesn't work, maybe a reinstall of just the system is in order. I don't know about you but when I do an install my "/home" is always on a seperate partition that way as a last resort I can reinstall from the cd and not lose any data. If that doesn't fix it you may want to reopen another question or uncheck my answer and hopefully get some more input. – Kheldar Aug 14 '11 at 19:49

You could also have tried to use unity --reset. You can probably still try it if that works.

  • I should have mentioned that. (It's hard keeping the updates straight between different sites). I've tried unity --reset as well as gconftool-2 --recursive-unset /apps/compiz-1 with no effect. – Kris Harper Aug 14 '11 at 20:41

From your latest update I think there is a fundamental incompatibility with the 270 drivers and your graphics card.

This bug report - post #9 reports this issue with the 270 drivers and your graphics card.

Can I suggest you deactivate the 270 drivers and activate - specifically - the 173 driver.

  • I'm not sure the 173 driver will work. The driver page doesn't list my graphics card (GTX 460 SE) as a supported product. I'll certainly try if you think it'll work though. Relatedly, this seems to be the driver page for my card, and the drivers are at 280 there. I may be able to fix the problem by downloading those (presumably updated) drivers. I'll give this a try when I get home this evening. – Kris Harper Aug 15 '11 at 15:35
  • Okay, installing the 280 drivers didn't help, unfortunately. I went ahead an tried removing them and installing the 173 drivers like you suggested. As I suspected, they weren't supported and I had to boot into single user mode to reinstall the 280 drivers. As far as I know I'm up to date on my graphics drivers. – Kris Harper Aug 16 '11 at 0:39
  • :( - does the Additional Drivers window now say that nvidia 280 is activated AND in use? – fossfreedom Aug 16 '11 at 7:29
  • Oh damn! I can't believe I didn't check that. I'll have to wait until I get home tonight to look. I suspect not, but we'll see. – Kris Harper Aug 16 '11 at 13:16

Have you tried delete/rename/move ~/.config/compiz

rm ~/.config/compiz
  • I have not tired that. I deleted a bunch of other files (.compiz, .gnome2, etc. See above), but not this one yet. I will try when I get home this evening. – Kris Harper Aug 15 '11 at 15:25
  • There was a .config/compiz-1 folder, which I deleted with no effect after a reboot. There wasn't any compiz folder though. – Kris Harper Aug 15 '11 at 22:56

It's probably a bug in compiz. It used to happen to me a lot, but recently it has happened very few times.

I can always unfreeze the UI by moving to another Space (shortcut Control+Alt+*Arrow by default). You could try that and see if it works for you, but it's a workaround and there's definitely a bug somewhere, be it in compiz or in nvidia's driver.


I eventually just did a complete reinstall. I only copied my data, no settings or anything else. I didn't want the problem to follow me to a new install. This fixed the issue.


ubuntu 12.10 and 12.04: i had a very similar situation, where keyboard input suddenly stopped being recognized AND windows could not be moved, but CTRL+ALT+DEL worked and i could click on some links.

i found out that my problem was with SOUND SHORTCUTS (starting with BACKSPACE). i disabled every one of them (settings > keyboard > shortcuts >sound) and haven't had that problem any more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.