5

The problem is that my new Lenovo Yoga 2 Pro (lshw results) does not resume from suspend very well. I've collected the following data:

  1. This happens on Ubuntu 14.04.1 LTS - both with the original kernel and with the latest 3.16 kernel - and Ubuntu 14.10.

  2. The problem only happens when I suspend by closing the lid. It doesn't happen when I suspend from pm-suspend utility. I even went as far as running the following:

    while true; do sudo pm-suspend; sleep 5; done
    

    I placed a heavy object on the keyboard, which causes the laptop to immediately resume - and left it for an hour. It never failed to resume correctly. However, when closing the lid, approximately 1 out of 2 closures it will freeze.

    (edited) Another data point, not sure if relevant - when I suspend with pm-suspend, the machine won't resume at all when I close the lid and re-open it. When it suspends as a result of closing the lid - opening the lid will resume it... and then the UI freezes. I checked Windows 8.1, and that seems to happen as well - if I command it to sleep, it stays asleep even if I close the lid and re-open it.

  3. The computer doesn't freeze, only the window manager. The mouse still moves, but the screen does not update and nothing can be clicked. Switching to a VT works and I'm able to restart the lightdm service and regain control of the GUI:

    sudo service lightdm restart
    

    (at the price of closing all of the graphical applications I had running, so this is not a workaround).

  4. It's not lightdm's fault - I stopped the lightdm service and ran startx from the command line. It produces the same symptoms.

  5. There's nothing unusual showing up on /var/log/pm-suspend.log - I compared it with the output of other people's online posts, and couldn't find a difference. It looks the same, and all important activities succeed.

  6. I've modified /usr/lib/pm-utils/video-quirks/20-video-quirk-pm-lenovo.quirkdb - I added every combination of quirks I could think of, to no avail.

  7. Nothing unusual shows up on dmesg - I thought the Intel drive crashed sometime, but it seems to be unrelated because I can't correlate those crashes to a suspend / resume event chain. It seems to be in the Bluetooth driver anyway. I posted a sample in pastebin.

I'm really out of ideas at this point.

(edited) Well well... just as I was about to turn in, I stumbled across what seems to be a valid workaround. I missed it before because it didn't refer to a version of Ubuntu I was using, but the solution proposed does work for me. Still, I'd like to have a more... elegant... solution, if possible.

  • Is the pasted workaround still working for you? I'm trying it in Ubuntu 15.04 on my Lenovo Yoga and it isn't working. Your manual pm-suspend command works great though! – Samuel DeHuszar Allen Jun 13 '15 at 17:52
  • Can you please post the work around as an answer, if it indeed worked for you? – RolandiXor Jun 13 '15 at 21:09
  • @SamuelDeHuszarAllen it was working until a week ago, when my Yoga 2 pro was stolen :( – Arik Baratz Jun 17 '15 at 19:17
  • @RolandiXor I guess I don't know how this stackexchange works - when I tried posting an answer referring to the other answer, it converted it to a comment. – Arik Baratz Jun 17 '15 at 19:20

protected by Community Jun 13 '15 at 21:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.