8

I just updated from 14.04 to 14.10 yesterday. Today I stumbled on a bug in Image Viewer. Tried to report as per https://help.ubuntu.com/stable/ubuntu-help/report-ubuntu-bug.html but after "Collecting problem information", it just leads to "The problem cannot be reported. The report belongs to a package which is not installed." So here I am at askubuntu. This was my first time using 'ubuntu-bug', and I was unclear on the correct syntax for the program name, like, case sensitive? space between words, or no space? Either way, I figure I did it right given that "Collecting problem information" launched.

Bug: In Image Viewer, with an image displayed in "fit to screen" size, I left-clicked turning the mouse pointer into a closed-hand 'grabber', and tried to drag the image a bit. The image doesn't move of course, as the whole thing is already displayed. But then releasing the mouse button, the pointer remained like a little thumbnail of the image, but only the lower half. The upper half was 2 pointer arrows, side by side. I could not undo this and get a normal pointer again, until after reboot. Before that, I tried closing Image Viewer, then closing all other programs, then looking at Settings>Mouse... nothing would recover my pointer back to normal, until reboot. I've reproduced this problem 4 times now, needing 4 reboots.

Notably, when viewing an image in full-size where it exceeds the screen res, the grab & drag function works properly- pointer returns to normal after releasing mouse button.

As an unannounced 2-fer here, I'll also note that "Cheese Webcam Booth" would not open at all, resulting in an error message. Trying the same 'ubuntu-bug' report process above resulted in the same "The problem cannot be reported. The report belongs to a package which is not installed" message. But just now I tried launching CWB again, first time since most recent reboot, and it appeared to launch normally.

2
  • Bugs should be reported on Launchpad. However, it sounds like the "Image Viewer" package you selected is not the actual package to file against. Consider reporting the bug without assigning a package either, then triagers will get it to where it needs to be.
    – Thomas Ward
    Dec 28, 2014 at 3:08
  • 1
    By the way, the actual package is eog for the default-included image viewer)
    – Thomas Ward
    Dec 28, 2014 at 3:12

3 Answers 3

8

Try to open terminal and run

gsettings set org.gnome.settings-daemon.plugins.cursor active true

I got this from the https://bugs.launchpad.net/elementaryos/+bug/1430587. Hope it works, Good luck.

0
1

The bug is reported here: https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1406045 (reported on the same day as your post.. so someone must have read your post and reported it)

Thanks for trying to contribute a bug report! Keep up the good work. Next time, just make sure you get the package name exactly right. The package name can sometimes be different than what's displayed to the user. This package was "eog" rather than "Image Viewer" as it appears on the surface.

If you see another bug in eog, you could report it by being in eog, then going to help -> about. This will usually tell you some extra info about the application (including the version number which you'll have to include in your bug report). In the case of eog's about section, there's even a link to their website, where there's a "File a Bug" link.

0

From the link provided above: (https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1406045 ) To restore the pointer to normal click: ctrl + Alt + F1 followed by ctrl + Alt + F7 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.