6

Downloaded and burned ubuntu-14.04.1-desktop-amd64.iso. Checked md5 of iso and md5 of burned DVD.

Installed 14.04.1 LTS on a new Toshiba Satellite laptop. Replaced the existing Windows 8 install. The installation worked fine, but when I restarted it will not boot:

Reboot and select proper Boot device
or Insert Boot Media in selected Boot device and press a key

Turned off Secure Boot. Tried turning off UEFI Boot (CSM), but only got a blank screen with a flashing cursor, and Boot Repair did not work unless in UEFI mode.

Set the boot order to first hard drive, then DVD-ROM.

Ran Boot Repair several times, and changed the partitions around. Tried to create EFI partition, but Boot Repair kept complaining it was missing.

Finally deleted all partitions and reinstalled OS for 2nd time. Same symptom.

Changed the partitions to create bios_grub:

sda1 unknown   2 MB    bios_grub
sda4 fat32   510 MB    boot
sda2 ext4    461 GB    ----
sda3 swap      3 GB    ----

Used Boot Repair: Boot Repair pastebin

Followed several guides, but they all seem to show how to do a dual boot. This computer is not dual boot. Only Ubuntu.

2 Questions:

  1. How does the BIOS (UEFI) know which partition to boot? There are no options in the Toshiba BIOS startup utility.
  2. Why doesn't it boot? How to fix?

3 Answers 3

3

I own a Toshiba Satellite C50-B-14Z and did install Ubuntu Mate 14.04.1 LTS and works "Out Of The Box" except for screen dimming, but that's all talking about malfunction.

I've put an Samsung SSD 840 Evo in the machine to make ik much meaner (...).

After installing in UEFI mode I got the same "problems" but after turning CSM on/UEFI off and re-install Ubuntu (sorry, you háve to re-install...) it works flawlessly.

Erik

2
  1. UEFI settings for the Toshiba just allow you to set the device (HDD ). In UEFI, the partition marked with the boot flag is the location of the bootloaders. Then with a tool like efibootmgr, you can set the paths to bootloaders and their bootorder.
  2. It doesn't boot in UEFI mode because you have no bootloaders in the EFI partition.

Apparently you have switched to compatibility mode, putting a grub into the MBR, so that should work, but I have no experience with CSM on new machines. Some reading: help.ubuntu.com/community/UEFI

installing-ubuntu-on-a-pre-installed-windows

1
  • When I turn boot in CMS the screen stays black and I have to use an external monitor.
    – Natim
    Aug 21, 2015 at 8:53
2

I finally managed to install it correctly.

I created the following partitions:

  • /dev/sda1 150MB EFI (boot flag)
  • /dev/sda2 50GB /
  • /dev/sda3 4GB swap
  • /dev/sda4 70GB /home

Then I used the installer an click continue after the warning about UEFI mode.

Then after the installation I click continue testing.

I installed boot-repair:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair
boot-repair

In the advanced menu I verified that it was using /boot/efi in /dev/sda1

Then I ran boot-repair and restarted the computer. And everything worked.

1
  • Thanks for this. I had tried various combinations of possibilities, but the last hint about /boot/efi on /dev/sda1 did the trick.
    – Jos
    Mar 27, 2016 at 16:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.