1

Objective: Set up home multi-system (Mac, perhaps Win7, and other Ubuntus) backup capability using Seagate Backup Plus 3T drive connected to Ubuntu Studio 14.04. I would like to simplify the drive name and use the preferred (?) UUID/Labels to do so (to preclude changes in /sdx when I add/remove other external drives and reboot).

Approach: rsnapshot and rsync per Jeff Skinner's example. However, I formatted the drive as exfat (for multi-OS purposes), and sought to use Labels for the drive (calling it "BackupDrive")

Issue: I somehow ended up setting up a mount at sdd1 of /mnt/backupdrive as well as a mount at sdf1 with the label BackupDrive

From mount:

/dev/sdd1 on /mnt/backupdrive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

/dev/sdf1 on /media/will/BackupDrive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

From blkid;

/dev/sdf1: LABEL="BackupDrive" UUID="5053-2D7E" TYPE="exfat"

(there is no /dev/sdd1)

enter image description here

The only thing on the drive are standard Seagate files and some empty directories (e.g., no risk in losing data).

I can ls the files in /mnt/backupdrive and see the above files/directories.

It shows up on Nemo as BackupDrive though with no files or directories.

I have no real information on this backup drive yet

Question: How do I correct this to mount by UUID (or Label), so I can continue working my backup solution?

Once fixed, for rebooting purposes should I use;

sudo rm /etc/fstab.pre-uuid

sudo /var/lib/dpkg/info/volumeid.postinst configure

UPDATE: @Xen2050 - fstab has the following;

/dev/mapper/ubuntu--studio--vg-root /               ext4    errors=remount-ro 0       1
#" /boot was on /dev/sda1 during installation
UUID=5cade5c2-bd38-4d2b-aecb-b703ac671bc3 /boot           ext2    defaults        0       2
/dev/mapper/ubuntu--studio--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

The UUID for the BackupDrive in blkid and gparted is 5053-2D7E

The UUID 5cade5c2-bd38-4d2b-aecb-b703ac671bc3 is associated with the sda1 boot partition

UPDATE 2: Followed the suggestion of @xen2050 and added the following to fstab;

UUID="5053-2D7E" /media/will/BackupDrive  fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Rebooted, and it complained that there was a mount issue. I skipped the manual configuration during boot.

Here's what mount showed;

/dev/sdc1 on /media/will/BackupDrive1 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

blkid showed;

/dev/sdc1: LABEL="BackupDrive" UUID="5053-2D7E" TYPE="exfat" 

No existing files were shown in Nemo, though I copied a backup of the previous contents, and the drive shows them as resident there now. I don't understand why there is a BackupDrive1 showing up under mount

enter image description here

Will this work or am I still not out of the woods?

  • 1
    Try looking in the log files in /var/log/ for any mention of the mount error. Otherwise not too sure, maybe the fuseblk thing, usually mount tells the filetype like ext3, fat, should show exfat...? – Xen2050 Dec 28 '14 at 0:13
2

I think your directions (pasted from the Ubuntu uuid page) are outdated:

If you are using Ubuntu 6.06 Dapper Drake LTS, you can use these commands to "upgrade" to UUIDs. All other supported versions of Ubuntu automatically use UUIDs, so this is not necessary.

What's your /etc/fstab look like now? You can probably just change the "/dev/sd.." names to "UUID=..." in there and that's about it, like in the fstab help page. I think mount always reports what /dev device is mounted...

... saw updated fstab. I'm not too familiar with the "fuseblk" type, I've seen it before used with encryption but not in mount's output... but if it works that's good enough. The one says it's type "exfat" so maybe replacing fuseblk with exfat would work, or even auto...

So now the drive(s) get mounted with:

/dev/sdd1 on /mnt/backupdrive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sdf1 on /media/will/BackupDrive type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

So I think putting these into fstab should work for the sdf one:

UUID="5053-2D7E" /media/will/BackupDrive  fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Not sure about the sdd1 one, if blkid didn't see it...? Tried sudo blkid? Or there's only the one drive isn't there? Unplugging it could give it a different sdx "name"... so maybe that's what happened there to get the 2 different entries?

  • At this time, fstab has (sorry about the formatting, I can't get newline working); <br> /dev/mapper/ubuntu--studio--vg-root / ext4 errors=remount-ro 0 1 <br/> # /boot was on /dev/sda1 during installation UUID=5cade5c2-bd38-4d2b-aecb-b703ac671bc3 /boot ext2 defaults 0 2 /dev/mapper/ubuntu--studio--vg-swap_1 none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 This is a tad puzzling to me... – Will Dec 27 '14 at 21:19
  • Can you add that to your question (edit), formatted as a code sample? Can't make it out in the comment, they don't allow newlines... I do see a UUID=... so maybe it's already setup? – Xen2050 Dec 27 '14 at 21:24
  • Good idea, done adding the comment as an update to my original post. – Will Dec 27 '14 at 21:36
  • and now it is entered as code. – Will Dec 27 '14 at 21:48
  • Update 2 added, appreciating your help – Will Dec 27 '14 at 23:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.