1

Help! I changed my language on keyboard and I shut down my computer. Now keyboard doesn't work in English which I need to enter my password.

2
  • What language/locale did you set your keyboard to?
    – Gx1sptDTDa
    Dec 27 '14 at 14:43
  • The local language is Amharic
    – Anteneh
    Dec 27 '14 at 15:34
1
  1. Being on Log On screen, press Ctrl+Alt+F1 and it will take you to Terminal Screen.
  2. In the terminal screen, type the login name and password.
  3. Type the command, sudo dpkg-reconfigure keyboard-configuration.
  4. Press Ctrl+Alt+F7 to get back to GUI mode.

Now, you can login as usually it was before.

4
  • I followed the steps and at the end came a command prompt. What do i do now?
    – Anteneh
    Dec 27 '14 at 15:07
  • If you have executed the command given in the third step, press Ctrl+Alt+F7 to return to GUI, that is Log on Screen. From there, you could proceed login process.
    – Wolverine
    Dec 27 '14 at 15:13
  • It doesn't still type in English
    – Anteneh
    Dec 27 '14 at 15:29
  • Did you run the exact command given in the step 3? Make sure each step what I have given. These steps will definitely solve you the issue.
    – Wolverine
    Dec 27 '14 at 15:35
1

If you cannot access the Keyboard settings from the GUI, try running this command:

sudo dpkg-reconfigure keyboard-configuration

You can find more info here

To boot as root, at grub select "Advanced options for Ubuntu" then boot in "Recovery mode".

At the "Recovery Menu", you can choose "Drop to a root shell propmpt":

Running as root

If your keyboard is working, although not in the correct keymap, you should be able to type the command.

5
  • How should the OP type that command, if English is not available? Dec 27 '14 at 14:38
  • 1
    He changed the language, it's probably a keyboard mapping issue. If I get the answer, the keyboard does work, but not with the en-US mapping. Also he can run the terminal as root using the failsafe settings from grub.
    – Tico
    Dec 27 '14 at 14:43
  • Boot with bootable USB drive, then chroot.
    – Gx1sptDTDa
    Dec 27 '14 at 14:44
  • If you think there is a way, edit your answer, and elaborate. As is, it doesn't answer the question. Dec 27 '14 at 14:50
  • @mikewhatever, there.
    – Tico
    Dec 27 '14 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.