1

I cannot boot Ubuntu installed alongside with Windows 8.1 on my laptop with UEFI (Sony SVP1322R4RBI).

I followed the instructions on dual boot Windows 8 and Ubuntu, tried Boot-Repair with «recommended repair», then I manually set {bootmgr} option using Windows bcdedit, both

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

and

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

But there is no any effect, the laptop boots directly into Windows. Here is the report of Boot-Repair http://paste.ubuntu.com/9616775/

Maybe some advanced options would be helpful...

UPDATE 01

Here is my UEFI BIOS screens: link to dropbox (I cannot post images)

I've tried all F-keys, but I can't load boot menu.

Solved

I've renamed grubx64.efi into EFI\Boot\bootx64.efi, now everything is ok! As I understand, some models of Sony VAIO use only bootx64.efi bootloader.

  • If you're going directly to Windows, you should probably install grub again. You'll need to boot using a USB drive, or even selecting the partition in which Ubuntu is installed through the Boot Menu from your BIOS. – Tico Dec 27 '14 at 14:41
  • I have reinstalled grub via USB, no effect. – juliet Dec 27 '14 at 15:51
  • I've also checked with bcdedit that \EFI\ubuntu\grubx64.efi and shimx64.efi exist. – juliet Dec 27 '14 at 15:53
  • I'm pretty sure the following link will definitely solve your issue. howtoubuntu.org/…. – Wolverine Dec 27 '14 at 17:46
  • No, I cannot install grub on /dev/sda: grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible. grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.. grub-install: error: will not proceed with blocklists. – juliet Dec 27 '14 at 18:10
1

I renamed grubx64.efi into EFI\Boot\bootx64.efi. Now everything is ok. As I understand it, some models of Sony VAIO use only the bootx64.efi boot loader.

0

Ok. I've been looking at your Pastebin from Boot Repair, and here's what it looks like to me:

You've got all your partitions listed there, and it's listed which ones contain bootloaders.

/dev/sda1 seems to contain your Windows bootloaders and a secureboot handler /EFI/ubuntu/shimx64.efi for Ubuntu. I believe there should also be a grubx64.efi in the same directory as shimx64.efi, though, or it won't hand-off correctly.

/dev/sda3 looks like it contains Windows bootloaders and properly configured secure boot bootloaders for Ubuntu.

/dev/sda7 looks like it contains a traditional GRUB2 bootloader (and your Ubuntu installation). If you reboot and open up your EFI configuration tool at startup (just press whatever key the splash screen lists for "setup" or "configuration utility" before that boot splash screen disappears) and tell EFI to boot from one of the two partitions that have GRUB2 installed on it. I would choose the one installed on /dev/sda7, personally.

If Secure Boot isn't already disabled, I'd disable it. You say in another comment that you have found the option for that.

You may also need to change some settings to tell it to boot from that partition by default, depending on how your EFI setup utility behaves. If you set it to boot from GRUB2 by default, you should be able to use GRUB2 to choose which OS to boot from in future rather than having to use EFI. (The grub.cfg file reproduced in your pastebin looks like it does contain the entries for booting Windows by handing off to the Windows bootloader.)

If your EFI doesn't provide you with options of which device to boot in the setup (which it typically does do, so I'd be kind of shocked if it didn't give you an option anywhere to configure which device to boot from), there may just be a different key you need to press on the boot splash screen to get the boot device/partition options to appear.

If you can't find these options, perhaps you could provide some images of your boot screen and EFI setup utilities so we could look at them and see if we can spot the setting you need?

There is another option that may be worth pursing if we can't get this to work: properly installing GRUB2 to /dev/sda1 where the Windows bootloader lives. I would consider using partimage or dd to make an image of the partition, first, though. Then, if something went horribly wrong, you'd be able to restore the partition to its original state.

0

I had the same problem when I used to dual-boot and I enabled the windows bootloader to start when pressing F12(you can change this in the BIOS of your PC). I then pressed F12(you PC probably has a different F command) and chose to boot Ubuntu.

Downsides to this method:

  1. Windows will still boot automatically unless you press the F command when booting.
  2. Start up time for either OS will be slowed Down by the whole process
  • I have only UEFI/Legacy and Secure Boot Enabled/Disabled options in BIOS, but there is no any possibility to choose system boot. – juliet Dec 27 '14 at 18:13
  • Try with your F-Commands and see if you get to a menu that looks like the image in the link below. If you do chose the Ubuntu partition option. – William Dec 27 '14 at 19:06
  • encrypted-tbn2.gstatic.com/… – William Dec 27 '14 at 19:07
  • ignore the yellow arrow – William Dec 27 '14 at 19:08
  • I've tried all F-commands, but I cannot enter any boot menu. – juliet Dec 28 '14 at 15:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.