18

I know questions that sound like this one have been asked before, but none of the "solutions" are working for me. I am using Gnome Classic option.

  • I could not find any extension that does what I want.
  • I could not find any entry for gnome-panel in my dconfEditor

Will you please help me.

I installed Gnome 3 using sudo apt-get install ubuntu-gnome-desktop. I am talking of the panel visible in the following picture:

gnome3 classic - bottom panel

These are the list of extensions I have installed:

List of installed gnome shell extensions - part1 List of installed gnome shell extensions - part2

1
  • Now that you have added the bit about "GNOME Classic", I'm pretty sure Sneetsher's answer is the right one.
    – muru
    Jan 12, 2015 at 23:44

6 Answers 6

25
+200
  • It is the Window List plugin the same one used in Gnome Shell standard session which comes within gnome-shell-extensions package. It's full name:

    window-list@gnome-shell-extensions.gcampax.github.com
    

    Installed in: /usr/share/gnome-shell/extensions/

  • What it seems happening is .. the Gnome Classic session use it as a required plugin. So it does ignore disabling it. (Using gnome-tweak-tool)

  • To get rid of it, move it somewhere else or delete it

    sudo rm -r /usr/share/gnome-shell/extensions/window-list@gnome-shell-extensions.gcampax.github.com
    
  • To re-enable it, copy it back or reinstall gnome-shell-extensions.

    sudo apt-get install --reinstall gnome-shell-extensions
    
2
  • 1
    Disabling it didn't work. I deleted the extension and worked. Jan 13, 2015 at 6:45
  • As of Ubuntu 16.04, Gnome desktop (no Unity), simply start the Tweak Tool and disable and/or remove the extension, "Window List".
    – Codex24
    May 10, 2017 at 14:52
8

To check the current panels:

$ gsettings get org.gnome.gnome-panel.layout toplevel-id-list
['top-panel-0', 'bottom-panel-0']

Set the panel which you want to stay visible with Tried in Ubuntu 12.04:

$ gsettings set org.gnome.gnome-panel.layout toplevel-id-list "['top-panel-0']"

which will leave you with only the top-panel like you see in the snapshot below.

snap1

(With that done I wasn't able to Super + W or Alt + tab the minimized windows. But I haven't checked with other dock apps.. I suppose they'll work.)

To use both the panels again just run:

$ gsettings set org.gnome.gnome-panel.layout toplevel-id-list "['top-panel-0', 'bottom-panel-0']"
2
  • 1
    Doesn't work on Ubuntu 14.04. error: No such schema 'org.gnome.gnome-panel.layout' Jan 13, 2015 at 6:37
  • I installed gconf-editor but could not locate the entry to hide the buttom panel. This trick works perfectly. Thanks Jul 13, 2015 at 11:15
2

Apparently GNOME shows an option to delete panels on Alt + right click. On some machines it can be Alt + Super (the "windows" key) + right click. A menu should appear with the option to delete. If not, then I'm sorry.

EDIT: Didn't see the comment chain where you said that. weird stuff.

1
  • naah, thats not working
    – Chani
    Jan 12, 2015 at 19:53
1

onwards ubuntu 17.xx

just rename the metadata.json file in

/usr/share/gnome-shell/extensions/window-list@gnome-shell-extensions.gcampax.github.com$ 

and restart the system it will be disabled.

0

You can get a JavaScript extension such as this one which removes the bottom bar: https://sourceforge.net/projects/removebottombar/files/gnome-shell-extension-remove-bottom-bar-3.2-1.src.tar.gz/download

1
  • Can you tell me how to install it ?
    – Chani
    Jan 12, 2015 at 19:38
0

Install gksu if it isn't already, then press Alt+F2 which opens a small window. Type 'gksu nautilus' (without the quotes) and navigate to usr/share/gnome-shell/extensions/ , right-click window list and rename it. I named it window-lizt which disabled the extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.