8

I have a x64 tablet running win 8.1. I am trying to install different Linux distro's. Unfortunately I am having trouble booting up from live usb. I got all set up in bios, turned off secure boot, changed boot order. In bios I use boot override and choose usb. I discovered that bios won't let me boot a fat32 prepared live usb. Only ntfs worked (win 8.1 ntfs usb worked). Linux can't be ntfs prepared in a usb stick to boot from. There are some options missing in my bios which i have seen over the internet like csm?

Update:

When I choose "boot override" with an Ubuntu prepared usb stick the only thing that happens is that the screen goes black and then goes back to exactly where I was in bios menu, all this happens in a blink of an eye.

I also tried wubi, Ubuntu got installed, but when I try to boot, it boots to a Windows menu where I get to choose between Ubuntu and Windows. When I choose Ubuntu I get an error saying that I can't start Windows because of a change in hardware or software and I get to see this path \ubuntu\winboot\wubildr.mbr and it says that a file is missing.

Now from my experience on desktops and laptops, after installing Ubuntu or any other distro GRUB gets to take over the boot up and let you choose from the installed systems.

Any help is greatly appreciated.

Update 2:

Got it. Turned out that Bay Trail architecture bios firmware does not support booting outside uefi and has a bug which does not allow to boot anything else than 32 bit os. Linux 32 bit does not support uefi and linux 64 can't be booted since the firmware does not support 64 bit. However there is a bypass, after you have prepared your usb stick, go into the folder efi and copy to there a file named bootia32.efi, which you find here: https://github.com/jfwells/linux-asus-t100ta/blob/master/boot/bootia32.efi. Click on view raw and you will get to download. However this only solved the booting up of the live os usb. After installing I still could not boot Ubuntu.

  • Didn't seem to merit a down-vote to me, especially with no comment. If it's a dumb question, explain why it's a dumb question. – Marc Dec 26 '14 at 23:37
  • More info on the system would help. – Marc Dec 26 '14 at 23:38
  • It is a tablet running an Intel 3537 along with 2 gb of ram. Bios version is 2.16 Aptio from AMI. – Abdel Dec 27 '14 at 10:38
  • LOL Linux can be made to boot via NTFS. Read documentation carefully help.ubuntu.com/community/Installation/FromUSBStick – j0h Feb 19 '15 at 11:39
  • 1
    It might be more correct to say that Bay Trail tablet's firmware generally ONLY support 32-bit UEFI. The tablet may still support 64-bit OS. For example: kyledavidson.ca/blog/2015/3/15/… – david6 Apr 17 '15 at 22:59
1

Try Switching off UEFI and change to 'Compatibility" mode in the BIOS to see if it helps.(This may slow the boot of Windows unfortunately)

If not try this link which may help. https://help.ubuntu.com/community/UEFI

Good luck and ask for more help if necessary

1

I'm glad you got it. As far as wubi goes (for anyone taking a look at this): Wubi will not work will not work along side Windows 8 (which I assume you were using) as long as the system is a UEFI system.

For more information you can check out https://wiki.ubuntu.com/WubiGuide

1

I had same problem in one of my friend system. Its very simple with windows software 'rufus', just create gpt in uefi mode.

Or if you have still problem, 1. format your usb drive with fat32 and make it active. 2. Open iso file (using winrar or any app if Windows) and copy it's contents to pendrive. And boot in uefi mode.

Note- in bios setting, secure boot option must be off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.