0

I'm trying ton use my Mobility Radeon HD 4650 with Kubuntu 14.04. I've seen that the propriatory driver doesn't work with Kubuntu 14.04 and the new kernel and that I must use the free radeon driver. This is my laptop : http://doc.ubuntu-fr.org/toshiba_satellite_p300-27z/

But I've 2 problems :

  • After installing (with "nomodeset" to get installing working ; without "nomodeset" it freezed), my screen only works with à 1152x864 resolution and no possibility to choose 1440x900 which works fine with 12.04 and fglrx drivers.
  • my laptop is hot ; this was not so with propriatory driver

I tried more things but nothing works, so I need your help.

Thank's

meloli@Portable:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96 [Mobility Radeon HD 4650/5165]

meloli@Portable:~$ dmesg | egrep 'drm|radeon'
[    1.127440] [drm] Initialized drm 1.1.0 20060810
[    1.174627] [drm] VGACON disable radeon kernel modesetting.
[    1.174631] [drm] radeon userspace modesetting enabled.
[    1.175839] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.175841] [drm] No driver support for vblank timestamp query.
[    1.175844] [drm] Initialized radeon 1.34.0 20080528 for 0000:01:00.0 on minor 0


meloli@Portable:~$ glxinfo | grep vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

meloli@Portable:~$ LIBGL_DEBUG=verbose glxinfo 
name of display: :0
libGL: screen 0 does not appear to be DRI3 capable
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL: Can't open configuration file /home/meloli/.drirc: No such file or directory.
libGL: Can't open configuration file /home/meloli/.drirc: No such file or directory.
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_make_current_read
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float, 
    GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_buffer_age, GLX_EXT_create_context_es2_profile, 
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB, 
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:                                                                                                                                                  
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,                                                                                       
    GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating,                                                                                     
    GLX_MESA_copy_sub_buffer, GLX_MESA_multithread_makecurrent,                                                                                                  
    GLX_MESA_query_renderer, GLX_OML_swap_method, GLX_SGIS_multisample,                                                                                          
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGI_make_current_read                                                                                               
OpenGL vendor string: VMware, Inc.                                                                                                                               
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits)                                                                                             
OpenGL version string: 3.0 Mesa 10.5.0-devel                                                                                                                     
OpenGL shading language version string: 1.30                                                                                                                     
OpenGL context flags: (none)
OpenGL extensions:
........... (cut) ..............
3
  • Try the solution I described on this question: askubuntu.com/questions/688388/… remotely turn on your backlight. – Karl Mar 21 '17 at 8:54
  • Thank you for your answer. I usualy use radeon.dpm=0. What is the difference with radeon.modeset=0 in your link ? – Oli Apr 4 '17 at 18:11
  • I've tried the installation of Ubuntu 16.04.3 : it works without any modification. But with Ubuntu 17.04, i get a blank screen when need to start the graphical interface. Same problem with nomodeset or radeon.dpm=0. – Oli Aug 9 '17 at 17:51
0

Translated from here:

Once the system has started, edit /etc/default/grub and add to the end of the line starting with GRUB_CMDLINE_LINUX_DEFAULT the following: spaceradeon.dpm=0

The important this is to remove any nomodeset, present so GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=0 is the default, but don't replace any other kernel parameters you might have there already...

Then execute:

sudo update-grub

To get rid of the heat problem, we'll put the card itself into low-power mode:

sudo nano /etc/init.d/ati-power-save

Add the following lines:

#!/bin/sh
# ATI power save
echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile

(If you would like better performance, please replace low by default, auto, mid or high if needed. high will give the best performance, but also the highest T°.)

Save the file and make it executable:

sudo chmod +x /etc/init.d/ati-power-save 

Now create the links that allow the script to be executed at each boot:

sudo update-rc.d ati-power-save defaults 99 
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.