0

I got it off the ubuntu software center and it seems to install ok.

I navigate to

http://localhost:5984/

and get :

:( No data received

In terminal I do a

curl 127.0.0.1:5984

and get

curl: (52) Empty reply from server

I restart couchDB with

sudo stop couchdb

sudo start couchdb

Which gets me :

couchdb start/running, process 20545

Ive turned off my httpd (apache2) just to be sure thats not interfering.

When I do this in terminal (per http://docs.couchdb.org/en/latest/install/unix.html#first-run):

sudo -i -u couchdb couchdb

I get (among other things) :

Failure to start Mochiweb: eaddrinuse

Googling that got me this (source : http://wiki.apache.org/couchdb/Error_messages) :

Unavailable Port ...  Solution Edit your /etc/couchdb/couch.ini file and change the Port setting to an available port.

So in terminal I look in that directory and all thats there is :

default.d default.ini erl_crash.dump local.d local.ini local.ini~

So I google the usage of couchDB configuration files and find that I should be able to configure it by editing local.ini (source : http://docs.couchdb.org/en/latest/config/intro.html)

local.ini has in it (among other things)

;port = 5984

;bind_address = 127.0.0.1

The ; are comments so I uncomment those lines, save, and restart couchdb, and have the same problem.

So I wonder what could be listening on that port so I put this in terminal :

netstat -lnptu

And see only one entry for 127.0.0.1:5984

tcp        0      0 127.0.0.1:5984          0.0.0.0:*               LISTEN      -

No PID but I think its connected to this (using top) :

29264 couchdb   20   0 58596 3980 1808 S    1  0.1   0:00.03 beam.smp

So at this point I have no idea whats wrong or how to fix it, only that it dosent work and I kinda cant believe something so popular (couchDB and Ubuntu 12.04) dont work right out of the box.

What can I do at this point? Jumping out of a window isnt an option because its only a one story building and its cold outside.

0

I had the same problem. I am on Ubuntu 14.04.1 LTS, but perhaps my solution will help.

When I did a ps -ef | grep couchdb, I found the following in a process run by couchdb:

-couch_ini /etc/couchdb/default.ini /etc/couchdb/local.ini

I had already changed local.ini, but that didn't help. When I looked at default.ini, I saw the port and host set there as well, so I removed my changes from local.ini and added them to default.ini. After restarting couchdb, I had success.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.