4

Please I have problem on my mon0 interface I try different ways but still couldn't fix it. I want to turn on mon0. and here is the outcome.

# airmon-ng start wlan0

Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
722 avahi-daemon
730 avahi-daemon
775 NetworkManager
834 wpa_supplicant


Interface   Chipset     Driver

wlan0       Broadcom    wl - [phy0]mon0: ERROR while getting interface flags: No such device
                        (monitor mode enabled on mon0)


# airodump-ng mon0
Interface mon0: 
ioctl(SIOCGIFINDEX) failed: No such device
root@mbfada-Lenovo-G400:/opt/aircrack-ng# airodump-ng wlan0
ioctl(SIOCSIWMODE) failed: Operation not supported

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
Sysfs injection support was not found either.


# airmon-ng start wlan0

Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
722 avahi-daemon
730 avahi-daemon
775 NetworkManager
834 wpa_supplicant


Interface   Chipset     Driver

wlan0       Broadcom    wl - [phy0]mon0: ERROR while getting interface flags: No such device
                        (monitor mode enabled on mon0)
2
  • Try stopping processes that may cause problems: sudo stop avahi-daemon , sudo stop network-manager and killall wpa_supplicant if it is still running. Could you post your driver info lshw -C network.
    – user.dz
    Dec 27, 2014 at 9:37
  • Please, edit your question to include the output of: lspci -nn | grep -i net. Dec 29, 2014 at 15:28

2 Answers 2

2

Ubuntu's network manager is conflicting. You can turn set it to manual using

sudo stop network-manager
echo "manual" | sudo tee /etc/init/network-manager.override

After that you should be able to run

sudo airodump-ng start wlan0

Alternatively, you could also set

unmanaged-devices=interface-name:wlan0;interface-name:mon0

or for a hw address

unmanaged-devices=mac:11:22:33:44:55:66

This can be changed in /etc/NetworkManager/NetworkManager.conf under section keyfile. See also

man NetworkManager.conf
2
  • 2
    Instead of disabling Network Manager completely, one could also set unmanaged-devices=interface-name:wlan0;interface-name:mon0 (or unmanaged-devices=mac:11:22:33:44:55:66 for a hw addr). This can be changed in /etc/NetworkManager/NetworkManager.conf under section keyfile. See also man NetworkManager.conf.
    – Lekensteyn
    Jul 9, 2015 at 15:24
  • Arguably the better solution, i'll update my answer. Jul 9, 2015 at 15:31
1

Simply killing the processes works. You shouldn't need to unmanage the interface:

As an example:

kill 722 730 775 834
airmon-ng start wlan0

The numbers (pid in the kill) will be different most of the times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.