3

So I am attempting to add a theme to rEFInd, as I don't like how it looks, but I am a complete newbie when it comes to terminal and looking for usually hidden files. This is the theme I'm trying to use: Minimal Theme, and this is how you are supposed to install it:

   # cd /boot/EFI/refind/
   # git clone https://github.com/EvanPurkhiser/rEFInd-minimal
   # echo "include refind-minimal/theme.conf" >> refind.conf
   # systemctl reboot

Anyways, I have installed rEFInd correctly (I hope, as it said install complete) but I cannot find where it is supposed to be. locate refind.conf to no avail. Every time I tun the command above, I get cd: /boot/EFI/refind/: No such file or directory making it so it won't correctly install.

And one last question, I ran diskutil list and it said I have two EFI disks (is that what it's called?). Is that normal? Any other tutorial I look out, they only have one EFI.

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            700.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:        Bios Boot Partition                         3.1 MB     disk0s4
   5:                 Linux Swap                         1.0 GB     disk0s5
   6: 0FC63DAF-8483-4772-8E79-3D69D8477DE4               298.3 GB   disk0s6
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS FreeAgent GoFlex Drive  499.8 GB   disk1s2

I really hope all this made sense, I am just a complete newbie to all of this.

  • If you provide me with the commands you used to install refind itself, I should be able to help you locate your refind.conf and related files. Also, with regards to your two EFI partitions, from what I can tell /dev/disk1 is a USB harddrive. If that's the case, you only need to concern yourself with /dev/disk0. ALSO (:p) it doesn't look like you've installed Ubuntu with support. I'm seeing a hybrid table (EFI/EMULATED BIOS). Was this intentional? – amanthethy Dec 26 '14 at 5:30
  • @amanthethy I was in the middle of installing Ubuntu, but in the final part my flash drive broke errored out or something. The command I used to install rEFInd was sudo /path/to/unzipped_rEFInd file/install.sh only with the path actually written out. – Distracted Mori Dec 27 '14 at 5:29
  • You've got to mount your ESP partition as reFind now installs there by default. (It used to install to /boot/EFI) mkdir /Volumes/EFI && sudo mount -t msdos /dev/disk0s1 /Volumes/EFI After this, the folder with your refind stuff should be in /Volumes/EFI/. (ex. /Volumes/EFI/EFI/refind/) – amanthethy Dec 27 '14 at 7:43
  • Okay, so I tried it, and it worked. However when I reentered the way you are supposed to install the theme, but I got this error: baileys1106s-imac:~ moriarty$ cd /boot/EFI/refind/ -bash: cd: /boot/EFI/refind/: No such file or directory baileys1106s-imac:~ moriarty$ git clone https://github.com/EvanPurkhiser/rEFInd-minimal fatal: destination path 'rEFInd-minimal' already exists and is not an empty directory. baileys1106s-imac:~ moriarty$ echo "include refind-minimal/theme.conf" >> refind.conf baileys1106s-imac:~ moriarty$ systemctl reboot -bash: systemctl: command not found – Distracted Mori Dec 27 '14 at 21:15
  • Well yeah... Your refind stuff is at /Volumes/EFI/whatever not /boot/EFI. – amanthethy Dec 28 '14 at 21:54
3

From OSX, do the following

Start by mounting your EFI partition.

sudo mount -t msdos /dev/disk0s1 /Volumes

Then cd to the rEFInd directory on that partition cd /Volumes/EFI/rEFInd

Download the theme with Git

git clone https://github.com/EvanPurkhiser/rEFInd-minimal

Now add the theme info to refind.conf

echo "include rEFInd-minimal/theme.conf" >> refind.conf

Reboot with sudo reboot

| improve this answer | |
  • When I did the cd /Volumes/EFI/rEFInd, I got "No such file or directory". What should I do? – Distracted Mori Jan 17 '15 at 0:30
  • That's what the folder is called on my machine. I have no idea what it would be called on yours, but I can be sure that whatever it is it will sit in /Volumes/EFI/ after you mount your ESP partition. Check that the spelling and path match what is actually on your machine. cd means Change Directory. So if you say cd /foo/bar and /foor/bar doesn't exist it'll give you the error you're getting. – amanthethy Jan 19 '15 at 17:16
-2

ReFIND Minimal Theme on Mac OS X Yosemite

In Terminal...

$ cd /Volumes/ESP/EFI/refind
$ git clone https://github.com/EvanPurkhiser/rEFInd-minimal
Cloning into 'rEFInd-minimal'...
remote: Counting objects: 182, done.
remote: Total 182 (delta 0), reused 0 (delta 0), pack-reused 182
Receiving objects: 100% (182/182), 3.35 MiB | 6.32 MiB/s, done.
Resolving deltas: 100% (74/74), done.
Checking connectivity... done.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.