2

I'm having trouble running ccminer 1.2 on my Lenovo IdeaPad-Z500 with a NVIDIA GT 740M which is a CUDA capable GPU according to https://developer.nvidia.com/cuda-gpus. I installed the CUDA toolkit following http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html (added the repository and updated the repos and installed cuda). Starting ccminer causes error

modprobe: ERROR: could not insert 'nvidia': No such device
[2014-12-26 03:26:50] Unable to query number of CUDA devices! Is an nVidia driver installed?

Invokation with optirun, i.e. optirun ccminer, alone and in combination with sudo, i.e. sudo optirun ccminer and optirun sudo ccminer causes

modprobe: FATAL: Module nvidia-uvm not found.
[2014-12-26 03:29:08] Unable to query number of CUDA devices! Is an nVidia driver installed?

Adding an alias to /etc/modprobe.conf in the form

alias nvidia nvidia-340
alias nvidia-uvm nvidia-340-uvm

doesn't change a thing. nvidia-340, nvidia-340-uvm (340.36) and bumblebee (3.2.1-5+xedgers14.10.1) are installed. optirun -vv bash gives output

[37049.350238] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[37049.350909] [DEBUG]optirun version 3.2.1 starting...
[37049.350962] [DEBUG]Active configuration:
[37049.350981] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[37049.350999] [DEBUG] X display: :8
[37049.351015] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-340:/usr/lib32/nvidia-340
[37049.351032] [DEBUG] Socket path: /var/run/bumblebee.socket
[37049.351049] [DEBUG] Accel/display bridge: auto
[37049.351066] [DEBUG] VGL Compression: proxy
[37049.351082] [DEBUG] VGLrun extra options: 
[37049.351098] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[37049.351308] [DEBUG]Using auto-detected bridge primus
[37051.419635] [INFO]Response: Yes. X is active.

[37051.419696] [INFO]Running application using primus.
[37051.419905] [DEBUG]Process bash started, PID 21812.

sudo modprobe -v nvidia-340-uvm causes error

insmod /lib/modules/3.18.1-031801-generic/kernel/drivers/video/nvidia.ko 
modprobe: ERROR: could not insert 'nvidia_340_uvm': No such device

which I don't understand. I added the xorg-edgers PPA ppa:xorg-edgers/ppa.

Currently the usage is unclear for me because there's no --help argument (requested as https://github.com/cbuchner1/ccminer/issues/29), but it might be retrievable from somewhere.

After installation of the CUDA examples with /usr/local/cuda/bin/cuda-install-samples-6.5.sh ~/cuda-examples/ I ran the deviceQuery binary which fails with

bin/x86_64/linux/release/deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

modprobe: ERROR: could not insert 'nvidia': No such device
cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

and optirun deviceQuery which fails with

bin/x86_64/linux/release/deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

modprobe: FATAL: Module nvidia-uvm not found.
cudaGetDeviceCount returned 30
-> unknown error
Result = FAIL
  • Use a different bitcoin mining software. – Thomas Ward Dec 26 '14 at 19:00
  • @ThomasW. Can you image that your comment in the current form is not as useful as it might be in another? It's not even a comment in the SE sense, but a (highly extensible) answer. – Karl Richter Dec 26 '14 at 19:09
  • Well, all I can say is try a different mining software. Hardware and/or software specific problems such as this one where it isn't detected by the miner are pretty infinitely broad and impossible to answer. I also don't support GPU mining except for fun and as a method to literally burn your computer - as GPU mining died a long time ago – Thomas Ward Dec 26 '14 at 19:27
  • @ThomasW. Sorry, I read your comment as a non-constructive opinion-(that there's a better mining software to be used instead)based one. – Karl Richter Dec 26 '14 at 20:56
2

I had this same problem and just got ccminer working by using auto Nvidia symbolic link with update-alternatives. Try this:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

choose auto (0) and enter

1

After reading the CUDA toolkit installation instructions and figuring out some compilation issues of the CUDA toolkit examples (following solution applies to them as well), I found out that

  1. cudaminer 746a7733dda9d2b3466c54c149362e4fb205cc3f works when invoked with optirun env LD_LIBRARY_PATH=/usr/local/cuda-6.5/lib64:$LD_LIBRARY_PATH CC=gcc-4.8 CXX=g++-4.8 LANG=C ./cudaminer with -o and -O option in source root after compilation with optirun env LD_LIBRARY_PATH=/usr/local/cuda-6.5/lib64:$LD_LIBRARY_PATH CC=gcc-4.8 CXX=g++-4.8 LANG=C make
  2. 1 shows that compilation (with the same parameters and commands) of ccminer 1.2 fails because the CC, GCC and CXX variables seem to be ignored

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.