2

I'm trying to install some software for a Mightex camera and the first step is to run a ./configure file, after getting a lot of messages where it checks for libraries it fails with the following:

checking if Qt is multi-threaded... no
Qt is not multithreaded (or its name is wrong). You MUST have a multithreaded
version of the Qt library installed or CamStream will simply not compile.

I think this is the relevant part of the configure file with regards to this message.

http://paste.ubuntu.com/9620162/

I'm running Ubuntu 14.04.

This link seems to indicate I need to install libqt-mt but I can't find that, or any other qt related library that is multithreaded.

UPDATE

After a bit more searching I found the package here:

http://packages.ubuntu.com/lucid/libqt3-mt

But it seems that qt3 is very old. What is the proper way to get this to work, ie not installing a really old package (seems like it was last in Ubuntu 12.04).

Also, trying to install it I got the following message:

Dependency is not satisfiable: libmng1 (>=1.0.3-1)

which I don't quite understand.

4
  • Which version of Ubuntu/Debian/Linux/whatever is this software meant to work with? To me this sounds like a software, which depends on outdated libraries. – s3lph Dec 26 '14 at 0:05
  • it's been tested with 12.04 nothing after. Am I all out of luck trying to use it in 14.04? – evan54 Dec 26 '14 at 0:13
  • That package seems to not exist in ubuntu 14.04. If someone figures out a way to get it in 14.04 I'll consider this closed, otherwise please edit this or provide a different answer. – evan54 Dec 26 '14 at 23:23
  • did you get it to work somehow in the end? – Zanna May 17 '17 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.