29

I installed teamviewer deb v10.0.036281 which is a 32bit?64bit Multi architecture one, it didn't worked well, so I tried to uninstall by using sudo apt-get remove teamv but got this reply

E: Unable to locate package teamv

am having Ubuntu 14.04 32-bit one

61

First, use the command

dpkg -l | grep team

The full package name should show up in the output on the list of installed applications. Find it and use the name listed. I believe it should look like this:

sudo apt-get purge teamviewer

or, if you want to use a wild card, you can use something like this instead:

sudo apt-get remove teamv*
| improve this answer | |
8

If you downloaded the .deb elsewhere (didn't install through apt-get) then you need to

sudo dpkg -r teamviewer 
| improve this answer | |
  • 6
    if it's a deb, it should be uninstallable through apt-get once it is installed regardless of how installation took place – mchid Dec 25 '14 at 22:20
3

The command below showed the full package name as teamviewer-host:

dpkg -l | grep team

I was able to remove it finally using:

sudo apt-get remove teamviewer-host
| improve this answer | |
2

To remove Teamviewer, run

sudo apt-get remove teamviewer
| improve this answer | |
1

Make sure you have typed the package name correctly. Otherwise you are trying to uninstall the one which is not installed.

| improve this answer | |
1

Run:

sudo aptitude remove teamviewer

If not installed aptitude, run:

sudo apt-get install aptitude

Use only aptitude, he is best installer deb pkg.

| improve this answer | |
1

You could run

dpkg --remove --force-all teamviewer

Worked fine for me. Apt-get did not work giving me the following output:

apt-get remove teamviewer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package teamviewer:i386 needs to be reinstalled, but I can't find an archive for it.

So using dpkg got me through this.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.